0

I got a Moto G (2nd gen) in an asian country. I have brought it to the US now and use a AT&T sim card, that has a 300MB monthly mobile data plan. I'm not able to use the internet although I keep mobile data switched on all the time. How can I fix this?

Yes, I tried turning the phone off and back on.

0

Your phone may not have the correct APN settings in it in order to connect and use the data properly. Check and add these settings if necessary.

Access the Settings menu. Locate and select Wireless & Networks or More Networks. Select Mobile Networks. Select Access Point Names. Locate and select the option to add a new APN. This is usually accessed by a + symbol on the screen or by tapping the menu button.

Under name, You may write what you choose. I would probably write "ATT" or similar Under MMSC, write http://mmsc.mobile.att.net Under MMS Proxy, Write proxy.mobile.att.net Under MMS Port, Write 80 Under MCC, Write 310 Under MNC, Write 410 The rest of the settings remain unchanged. After these settings have been entered, Turn off the phone, take out the battery and SIM and allow 5 Minutes to rest. After this, Turn the phone back on and see if you have data.

The settings I used can be found under "Correct Data Settings" at: http://www.att.com/esupport/article.jsp?sid=KB424489&cv=820.

My knowledge comes from years of experience with many different devices and Operating Systems.

Have an awesome day and Thank you! xD

  • Thanks man! the android devices part on link did the trick – raul Feb 7 '15 at 19:26
  • You are very welcome! Glad I could help!! – Jimmy Speegle Feb 8 '15 at 10:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.