0

Problem: Phone battery ran out. Popped spare battery in and the boot loop began. Can only go so far where the screen says "Samsung Galaxy S3 i9300" and nothing further.

Tried with no success:

  1. Flicking power button several times
  2. Vol Up + Home + Power = loop persists
  3. Vol Down + Home + Power, then Vol Up to select Continue and screen is just stuck in "Downloading.. Do not turn off target"

Please help :(

  • Might sound trivial, but have you tried pulling the battery out and replacing it? – Alfie J. Palmer Feb 13 '15 at 14:47
1

Sometimes getting into recovery takes several tries of the "Vol Up + Home + Power" combination and is pretty frustrating.

I know that for me, I generally hit the vol up and home button together, then while holding those hit power for a second and then let go again before hitting power again a few times and letting go of the original combination and doing that again.

Again, I've flashed several other phones before this where the combination always worked but somehow the i9300 is just weird.

Hope you get out of it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.