1

I have a Samsung Galaxy S5 (SC-04A), running Android 4.4.2, and it is rooted but still has the stock ROM that it came with when I purchased it. This problem has existed since before rooting the phone.

I leave the phone in its charging cradle over night. When I wake up, the phone is not connected to my home wifi network.

I have looked at the advanced wifi settings, and the option "Keep Wi_Fi on during sleep" is set to "Always". I do not have any "Wi-Fi timer" set. I can't see any other options that might make my Wifi disconnect.

How do I ensure that my Galaxy S5 is staying connected to my home network, and in general always maintains a stable connection to any network?

2
+50

Hmmm. Have you tried un-rooting and then get the latest OTA Firmware Updates? You can re-root afterwards if you want. (In OTA download: Look for files with _wifi in the name)

Or maybe try looking for custom ROMs if you feel ok messing with the Operating System.

Sometimes getting the right updates solves stuff like that. I've done it on both tablets and smartphones with great success.

  • Giving the bounty here because this is close to what I ended up doing. Basically, after a little struggle with getting the right firmware and ROMs, I ended up upgrading to an Android 5.0 ROM, and all my wireless worries seem to have gone away. – Questioner Feb 19 '15 at 6:37
3

Do you have a scheduled Titanium backup? That sometimes turns of my wifi when it runs.

Do an inventory of programs you have installed. A system app will not be turning off your wifi, but one you have installed may be doing that.

Install BootManager (free) and select programs you do not want to run at startup. That would be almost everything.

When the screen times out the wifi may be disconnecting, too, but wifi should automatically reconnect when the phone is unlocked. For testing you might install an app to keep the phone from going to sleep to see if losing wifi is related to sleeping.

  • Thank you for responding. I do have Titanium Backup, but it is not currently configured to run any scheduled backups. It is a good idea, though, to do an inventory of apps and see if any of them are impacting wifi. The only downside to this advice is that I have a lot of apps. It would be ideal if there were some way I could narrow the focus. – Questioner Feb 15 '15 at 6:07
  • Use BootManager to insure they don't start. That was said to eliminate possibilities, but probably is not the problem. It's probably the phone sleeping and wifi not automatically connecting when you wake the phone up. It may also be a power save setting. – subjectivist Feb 15 '15 at 6:17
1

I was thinking along the same lines as dmcdivitt on the power setting being the issue. I'm currently going through the same thing with an xperia z3, having just changed the power setting to Stamina mode.

If you keep having the problem but don't want to turn off stamina, try using an automator app like macrodroid or tasker to force a reconnect to wifi. I'm still in experimentation mode on this one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.