1

I'm building a website under ssl certificate. It just works on desktops but android browser argues that the ssl authority is not trustworthy. So to see the staging site I told it to just consider it trustworthy. Now it doesn't complain anymore.

But now I have to find a way to make the browser not complain for the ssl authority with any user, but I have no way to test the changes I'm doing, because now the browser considers the site ok. I want to set it back to original settings and get it complain again :) I cannot find a way, it seems I have no access to ssl/websites exeptions.

1

The certificate has most likely been added to your "trusted certificates". You can delete it in Settings › Security › Trusted Certificates then (Settings referring to the Android System Settings, not those of the browser used): chosing the "User" tab should display certificates you've added as user (as opposed to those the system already brings along, or you might have added manually with root powers to those).

In case the browser used ignored the central certificate storage, and dealt with it itself, you can either try finding the corresponding place in the browser's own configuration pages – or simply drop it all (all the browsers data, including cookies etc.) by going to Android's Settings › Apps › All, scrolling the list to find the browser you've been using, tapping its entry, and chose to "Delete data".

  • 1
    To clarify, that Settings refers to system settings, not the browser's settings. – Lie Ryan Feb 9 '15 at 10:33
  • Oh – yes, of course! Sorry I didn't make that clear. Will integrate that with my answer so it's not missed :) – Izzy Feb 9 '15 at 10:36
  • it's stange: the user tab is empty.. So what? :) – Luca Reghellin Feb 9 '15 at 10:41
  • Unexpected situation (me confused). Let's get to the guns: Delete app data from the browser? (instead of "atomics" doing a factory-reset :) Alternatively: Check with a different browser, check all browser settings one-by-one... If it's not in the certificates list, it must be something specific to the browser used. You didn't specify which it was in your case, so it's hard to say. – Izzy Feb 9 '15 at 10:47
  • Found the way: (global) settings > app > all > android browser > delete data. Then I'm able to have the browser complaining again for the certificate authority :) – Luca Reghellin Feb 9 '15 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.