3

I have a problem with my internal SD card on my android 4.2.2. It shows there are no files on the internal SD card but there is a shortcut called "legacy" and I can't write anything on the internal SD card or download on it but I can install apps on it.

I found on Root Explorer that the owner and group is set to root. I try to change to system but it does not change.

And the permissions is set to read and execute for the owner and group and other. The write permissions is disabled to the owner and group and other. I also try to change the permissions and unroot my phone but it does not work.

Is there any solution for my problem?

  • Did you tried formatting the whole SD card using your PC ??? – Peter Carlos Feb 9 '15 at 11:43
  • Open the legacy folder, the contents of your SD card are (usually) there. – GiantTree Feb 9 '15 at 14:17
  • Yes i tried to format the sdcard but the problem still exist – Ali Habbash Feb 9 '15 at 15:13
  • I try to enter the internal storage on my pc and there is no files or folders – Ali Habbash Feb 10 '15 at 21:25
  • And my pc set to show hidden and system items – Ali Habbash Feb 10 '15 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.