1

One of my friend had a Huawei Y210, it locked because of so many wrong pattern attempt. Unfortunately he hasn't google account to login with it.

I want to hard reset it but it fails to load Recovery mode by pressing Volume Up + Power for more than 10 seconds or less!, I tested any key combination but only it normally boots and shows locked screen.

I tried fastboot -i 0x12d1 flash recovery recovery.img and without vendor id, it only waits for device.

Also I added 51-android.rules to udev and restart udev but nothing happend and only wait for device.

and adb only waits for device.

I have no idea what I should do. If I setup a bootable sdcard, Can it boots from it? or like NoteII that can goes to recovery mode by soldering some resistors to a male usb connector and plug it, there is something like this?

  • possible duplicate of Enter recovery mode from command line – Ryan Conrad Feb 9 '15 at 19:00
  • No duplicate, if you read them correctly you can distinguish them – Farhadix Feb 9 '15 at 19:05
  • Duplicate or not, it is related. The only difference is that your device is locked because of wrong password attempts. You are looking to get into Recovery without hardware buttons, as you state they didn't work. That question covers that. You also state that adb wasn't working as it was 'waiting for device'. – Ryan Conrad Feb 9 '15 at 19:13
2

Finally I found the way:

Turned it off and then connect it to computer, adb found it as recovery then i ran adb reboot recovery and then it reboots to recovery.

I found that volume up and down keys are semi broken and for this reason it could not to load recovery mode.

0

To enter fastboot mode hold vol+ vol- AND power for about 5 seconds; then check with fastboot devices

this assumes you've already installed the adb drivers from hi suite or some universal set.

once you're here you can flash a custom recovery or extract the factory recovery from the firmware zip.

http://consumer.huawei.com/en/support/downloads/detail/index.htm?id=14221

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.