I have installed the C++ redistributables, but everytime I try flashing ClockworkMod Recovery, it fails with an libusb error: -12

C:\Users\new1\Desktop>heimdall detect
Device detected

C:\Users\new1\Desktop>heimdall flash --recovery cwm5_recovery.bin
Heimdall v1.4.0

Copyright (c) 2010-2013, Benjamin Dobell, Glass Echidna

This software is provided free of charge. Copying and redistribution is

If you appreciate this software and you would like to support future
development please consider donating: [donate link]

Initialising connection...
Detecting device...
ERROR: Failed to access device. libusb error: -12

C:\Users\new1\Desktop>heimdall detect
Device detected

I have tried on all of my USB ports, even tried 3 different USB cords Any ideas?

1 Answer 1


Inside Heimdall zip there is a driver folder.

  • Run the zadig.exe

  • click options - List All Devices

  • Choose your phone from the drop down list (on my pc it was "MSM8960"

    • I could not get it to work correctly on my PC, onece plugged into laptop "SAMSUNG Mobile USB CDC Composite Device")
  • Go through the drivers (WinUSB, Libusb0, Libusbk) and clikc Place drive for each of them.

  • Then run Heimdall

This worked for me but I had to do it on my laptop to be able to flash the files correctly.

I still get problem installing with my phone having an issue with the downloading bar going all across the screen and then stopping the flash.

to get around this I did one file at a time and allowed it to auto reboot. Each time putting it straight into download mode.

Source: http://redialflash.blogspot.co.uk/2013/05/how-to-install-and-succesful-start.html

  • thanks for the reminder, thats exactly what i was trying to remember. Commented May 13, 2016 at 19:23
  • 1
    Replace driver for each of them? Meaning click it repeatedly for all of them? Mine shows up as Gadget Serial twice, one of which is using the Modem driver and one of which is using the dg_ssudbus driver
    – endolith
    Commented May 11, 2020 at 5:56
  • 1
    github.com/pbatard/libwdi/wiki/Zadig says just one
    – endolith
    Commented May 11, 2020 at 6:01
  • 1
    For me installing the libusb0 driver was enough for me to use Heimdall. I don't think installing each of them in turn is useful, since the last one just overwrites whatever you had installed previously, i.e. only one of them can be installed at any given time.
    – EM0
    Commented Dec 27, 2020 at 16:34
  • For me with S22 Ultra it was called just "SAMSUNG USB", and i had 2 of them, the correct one had the driver "dg_ssudbus", the wrong one had "modem-something-driver" and I replaced the correct one with WinUSB 6.1-something driver :)
    – hanshenrik
    Commented Oct 22, 2023 at 16:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .