0

Is there any way I can install Chrome on my Lollipop x86 image. I tried installing it via ADB, but I get an INSTALL FAILED NO ABIS error. I was able to get ES File Explorer to load and I pushed chrome.apk to /sdcard. When I tried installing from ES, it gives me App Not Installed. I also tried installing Amazon AppStore but got the same error so it is not related to Google APIs.

So is there any way I can get apps to work on my x86 Intel image? ARM is really slow and choppy.

  • Get a x86 build of that app. Most apps are only compiled for ARM because of the native libraries they use. Play Store for instance takes care of determining which apps are compatible with your device. – GiantTree Feb 11 '15 at 16:05
  • Could you please point me to it (link to .apk file)? Also, is there any place where I can get x86 .apk files? – LakshyaAg Feb 11 '15 at 16:08
  • Well, you have to take a look inside the apps yourself. Some come bundled with both (/lib/x86 exists together with some arm* folders) or without any at all (no /lib folder); those can be installed without further issues. If there is only a /lib/arm* folder, then you are out of luck and have to search for one that has a /lib/x86 folder inside of it. – GiantTree Feb 11 '15 at 16:16
  • Also many free or open source apps have their x86 builds available on their websites (VLC for instance) – GiantTree Feb 11 '15 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.