1

I have a luks encrypted file in stock Android 4.4.4 that I want to mount to work with. It is located in the internal sd partition (/sdcard). I am able to mount it as root via su without problems.

However, other apps an users see the folder as empty. They can even write and remove files of the folder, so no permission problem. But they cannot see what root sees, nor root sees what the normal users do in the folder.

I tried mounting the encrypted file inside /storage, inside /storage/extSdCard and inside the /sdcard itself, always with the same result.

I'm not sure which data to provide, please ask.

Thanks!

migrated from superuser.com Feb 11 '15 at 17:13

This question came from our site for computer enthusiasts and power users.

  • How did the encrypted file/container get created? – Xen2050 Feb 11 '15 at 5:38
  • It was created with cryptsetup. BTW, the file works fine in CyanogenMod, but not in Stock Samsung Android 4.4.4. It smells to me like a bug. – Luis A. Florit Feb 12 '15 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.