1

I just got a new 64GB micro SDXC card for my Samsung Galaxy S2.
I had the same one already before, but after 3 years it said goodbye and had to be replaced (I can still read all data, but writing is impossible).

I am now trying to copy all data from the old SD card to the new one and here's the problem:
Writing to the new card while it is in the phone through Android is no problem at all. As soon as I use an adapter and put it into my PC (tried both, Win 7 and Linux), it is read-only. And I tried two adapters with the lock switch in all possible positions. Still read-only.
I noticed that Android (4.1.2, rooted) formatted the SD card as exFat, but my old card was Fat32. I downloaded AParted and reformatted the card to Fat32, but no changes.
I tried unmounting it properly before shutting down the phone and inserting the card into my PC. Doesn't help, either.
I inserted the card into the phone, connected the phone to my PC. Then I could add data onto the SD card, but the folder ".android_secure" which seems to be necessary for apps to work that have been moved onto an SD card fails to copy because Android doesn't allow that. That was close, but in the end useless because .android_secure could not be copied - and I have a lot of apps on SD.

Any hint on how I could get the last method work (maybe there is a special startup mode for the phone which allows me to access the SD card from my PC without locking ".android_secure"?) or something else? I mean I really have to be able to use the SD card on my PC! I'd appreciate that a lot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.