3

First of all, I am a newbie to Android. I am using Ubuntu Gnome 14.10 to run all the commads.

I am trying to unlock the bootloader of my Lenovo A536 (stock Android 4.4.2 aka KitKat). Here is what I am trying to do:

$ adb devices # lists the devices, apparently working List of devices attached 0123456789ABCDEF device

$ adb reboot bootloader # no terminal output; phone enters fastboot (there is written '=> FASTBOOT mode...' in the bottom-left corner

$ fastboot oem unlock # and here it stops without exiting; I have to force quit ... the fastboot by holding the phone power button for over 10s and then the command in terminal ends'

Before doing this I checked the USB debugging in the Developer’s menu.

Update #1
lsusb output (part of it) while the phone is connected to pc and booted in fastboot:

$ lsusb Bus 002 Device 064: ID 0bb4:0c01 HTC (High Tech Computer Corp.) Dream / ADP1 / G1 / Magic / Tattoo

Update #2 I found out that after installing a USB VCOM Driver on a Windows machine I was able to flash TWRP 2.7.1. I think Linux somehow does not recognise my phone.

Here is the link with tutorial to flash TWRP 2.7.1 using Windows. Note that before running SP Flash Tool, you must connect phone without battery to the computer, and after selecting the scatter file, you must insert battery into phone, otherwise SP Flash Tool would not flash anything.

  • Does lsusb show the device connected while it's in fastboot mode? Do you have the appropriate entries in /etc/udev/rules.d/51-android.rules? You might also have better luck running the command as the superuser. – Matthew Read Feb 15 '15 at 2:28
  • @MatthewRead – I have just appended the lsusb output to the question. And I have not such file as /etc/udev/rules.d/51-android.rules – should I create one? what should I contain? And running the command as superuser has same results. – tukusejssirs Feb 15 '15 at 11:48
  • I just created the file with sudo sh -exec "echo 'SUBSYSTEM=="usb", ATTR{idVendor}=="17ef", MODE="0666", GROUP="plugdev"' > /etc/udev/rules.d/51-android.rules" && sudo chmod a+r /etc/udev/rules.d/51-android.rules (using 17ef for the phone is a Lenovo), but still it hangs with the elipsis … – tukusejssirs Feb 15 '15 at 19:57
  • I tried even sudo sh -exec "echo 'SUBSYSTEM=="usb|usb_device", ATTR{idVendor}=="17ef", ATTRS{idVendor}=="17ef", MODE="0666", GROUP="plugdev, OWNER="ts", SYMLINK+="android_adb"\nSUBSYSTEM=="usb|usb_device", ATTR{idVendor}=="17ef", ATTRS{idVendor}=="17ef", MODE="0666", GROUP="plugdev, OWNER="ts", SYMLINK+="android_fastboot"' > /etc/udev/rules.d/51-android.rules" && sudo chmod a+r /etc/udev/rules.d/51-android.rules && udevadm control --reload-rules, and then adb reboot bootloader && fastboot oem unlock, but the result is still the same. – tukusejssirs Feb 15 '15 at 21:35

protected by Community Aug 2 '15 at 20:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.