0

I have a verizon S4 with which I plan to do some android development. Samsung's download website doesn't have a usb driver for the above mentioned model number. I installed SCH-I545ZKAVZW's usb driver because it is for 16gb black mist devices, but android studio doesn't pickup my device.

  • You could try the universal ADB driver: adbdriver.com/documentations/… – Matthew Read Feb 15 '15 at 2:20
  • Adbdriver's installer wizard doesn't pick up my device. My device isn't rooted, is that a problem? – u530891 Feb 15 '15 at 2:40
  • No, it shouldn't need to be rooted. What are the device IDs? (Open Device Manager, click on the Properties for any Android device shown, go to the Details tab, and look at Hardware IDs). – Matthew Read Feb 15 '15 at 2:42
  • Oops. Thse are the hardwar ids listed for the galaxy s4: USB\VID_04E8&PID_6860&REV_0400&MS_COMP_MTP&SAMSUNG_Android USB\VID_04E8&PID_6860&MS_COMP_MTP&SAMSUNG_Android USB\SAMSUNG_MOBILE&MS_COMP_MTP&SAMSUNG_Android USB\SAMSUNG_MOBILE&MI_00 USB\Vid_04E8&Pid_6860&MI_00 USB\Vid_04E8&Pid_6860&Class_06&SubClass_01&Prot_01 USB\SAMSUNG_MOBILE&Class_06&SubClass_01&Prot_01 – u530891 Feb 15 '15 at 2:54
  • What version of Windows do you have? – Matthew Read Feb 15 '15 at 3:08
1

I suggest that you modify the Google USB Driver so that it is installed for your device.

If you have the Android SDK installed, edit this file:

C:\Program Files (x86)\Android\android-sdk\extras\google\usb_driver\android_winusb.inf

Otherwise, you can download the driver here and edit android_winusb.inf from wherever you extract that archive to.

Edit the [Google.NTx86] and [Google.NTamd64] sections to add these lines under both:

;Samsung Galaxy S4
%SingleAdbInterface%        = USB_Install, USB\VID_04E8&PID_6860
%CompositeAdbInterface%     = USB_Install, USB\VID_04E8&PID_6860&MI_00

Now you want to install the driver by right-clicking adb_usb.inf and choosing Install (make sure your device is connected). It will probably give you an error about Driver Signature Verification. Depending on your version of Windows there are different ways to temporarily disable that; here is a good guide for Windows 8. Once it's disabled, install the .inf file and you should be good to go.

  • I followed every step, the galaxy s4 still won't show in android studio. – u530891 Feb 15 '15 at 4:12
  • @u530891 That is very odd. Are you able to transfer files and such to the device from your PC? – Matthew Read Feb 15 '15 at 4:24
  • You may be right. The connection is very intermittent. I tried 3 different cables, same problem. Wondering if the micro-usb port in my phone is gone. – u530891 Feb 15 '15 at 5:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.