I have alcatel onetouch pop with jellybean 4.2.2. I put into 32 Gb sd hc card. Card did not work correctly. Sometimes (specialy when i tried write more that one file) card has blocked with something like read-only mode. In that sitiation I used to connect my phone to computer (win 8.1) and run disk checking from properties. thats usuly had fix problem. Now my friend have switched on developer mode on my phone and my computer stoped seeing phone. I can't switch off dev mode, and I don't know how to repair sd card. Sorry for my English. Anyone can help me?

2 Answers 2


First, stop letting your friend mess with your phone. :) Dismount the card on your phone (or shut the phone down), remove the card, and use a compatible USB card reader to mount the card on your Windows computer.

At that point I would strongly suggest you copy off all the files from the SD card to your computer. After that reformat the SD card, using either the official utility at https://www.sdcard.org/downloads/formatter_4/ , or by putting it back into your phone and having it reformat it. (I strongly suggest the first option!)

If you encounter problems with any of this, chances are your card has been damaged beyond repair, perhaps by the flash memory write cycles being exhausted. Grab what you can and get a new one.

All of this, by the way, assumes you really have a micro SD card, or a full-sized one that you've verified the write lock tab is set properly.


I formatted the card as FAT32 and didn't work. I uninstalled the application (for access rights). Nothing. What worked for me WITHOUT rooting the phone. Format the card from the phone, not computer. If you don't find the formatting facility then you can format the card as NTFS. Then insert the card. The phone will notice you it is faulty and give you the possibility to format it. After that it should be solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .