Linked Questions

20 votes
3 answers
45k views

How to recover a deleted file from /data partition on a rooted phone?

I factory reset my rooted Android M phone but now I realize that there was a file in the /data directory which I need. Is it possible to create an image (.img or something similar) of the /data ...
K. Hatake's user avatar
  • 315
10 votes
4 answers
10k views

How disk space is used on Android device?

I have critical low storage level and can't understand what takes much of it and how that's possible that the installed applications can use 7 GB? I only use a few social media clients without any ...
turik97's user avatar
  • 221
14 votes
1 answer
17k views

How to stop apps writing to "Android" folder on the SD card?

I have a (seemingly) simple question to which I haven't found a clear answer to. My phone creates an "Android" folder on my SD card and I'm wondering if it could be moved into the phone's internal ...
Doctor Dumb's user avatar
14 votes
2 answers
29k views

How can I make a symlink (or equivalent) inside /storage/emulated/0?

So, I have rooted my phone (GT-i9505 with android 5.0.1) and I would like to move my WhatsApp folder to my external SD card to save 3GB on internal storage. This is what I tried so far. EDIT: ...
Mauro F.'s user avatar
  • 263
12 votes
2 answers
23k views

How to access /storage/emulated/10 (multi-users env) in adb shell on Android 9+ without root access?

I have two Android system users configured. $ pm list users Users: UserInfo{0:Owner:13} running UserInfo{10:security space:13} running UserInfo{999:XSpace:800010} running When the mobile ...
sgon00's user avatar
  • 352
10 votes
1 answer
17k views

How to bind mount a folder inside /sdcard with correct permissions?

I am using a Sony Xperia M4 Aqua. As is well known, the internal memory is rather small. Especially the Media directory of WhatsApp uses a lot of precious space, therefore I am trying to move it to ...
francesco's user avatar
  • 153
6 votes
1 answer
27k views

Is it possible to change file permissions on Android's internal storage?

How can I change file permission of a file on Android without rooting? I actually want to prevent some files from deletion. Note: I am asking of changing the file permissions of user-created files in ...
Puspam's user avatar
  • 602
5 votes
2 answers
57k views

Are files created in "/storage/emulated/0" supposed to appear in "/storage/sdcard0"?

From what I guess, internal storage is available by every user. If emulated storage is a storage location, made for a specific user, are files created in /storage/emulated/0 supposed to appear in /...
Narcotixs's user avatar
  • 213
8 votes
2 answers
17k views

How to change the modified date of a file without root?

How do I change the modified date of a file, specifically PNGs, on Android without root? Total Commander failed to do it with a permission error Access Denied.
Bernard's user avatar
  • 181
4 votes
4 answers
4k views

Why is there so many identical Android folders?

I was using the ES File Explorer app, when I noticed there's many different folders with all the same content. Like, there's a "legacy" folder, a "0" folder, and an "sdcard" folder, and it all goes to ...
jerrett7's user avatar
  • 172
6 votes
1 answer
7k views

Why can't I see Android storage as a partition on PC?

I'm trying to recover an accidentally deleted video from Huawei P10. I use Ubuntu, so I tried to recover it using photorec. The problem is that I can't see the mobile's internal storage or SD card ...
Milano's user avatar
  • 161
8 votes
1 answer
14k views

How do I access `$HOME/storage` outside of Termux (with a file explorer)?

How do I access $HOME/storage Termux directory on Android Pie with a GUI File Explorer? In Termux I print the working directory with pwd and it shows $HOME/storage as: /data/data/com.termux/files/...
Display name's user avatar
4 votes
1 answer
6k views

Why do partitions get unmounted automatically after some time?

I have an Android phone running Oreo 8.1.0. I have two partitions in sdcard. One partition is ext4 formatted. I mount it using: mount -t ext4 -o rw /dev/block/mmcblk1p2 /data/sdext2 But after some ...
jonny789's user avatar
  • 365
2 votes
3 answers
11k views

Two types of internal storage, what is the difference

When I go to System Settings > Storage’ I see two storage classification both by the name ofInternal Storage` one is around 2 GB and other is 11 GB. Also there is no SD Card present in my device. ...
Nullpointer's user avatar
2 votes
2 answers
13k views

Why chmod gives "Operation not permitted" error?

I try to execute chmod on a file with Termux, but it sends back an error which I'm unable to solve. My phone is not rooted. If you can help me I would be most grateful to you for this! Here is the ...
ARK's user avatar
  • 21

15 30 50 per page