Linked Questions

19 votes
4 answers

Why can't I get root access from shell?

> adb shell sh-4.1$ su Permission denied I have rooted my phone successfully. I know this because I'm able to install apps on SD card and I have a program called SD Maid that is able to operate ...
Kshitiz Sharma's user avatar
20 votes
3 answers

How to recover a deleted file from /data partition?

I factory reset my rooted Android M phone but now I realize that there was a file in the /data directory which I need. Is it possible to create an image (.img or something similar) of the /data ...
K. Hatake's user avatar
  • 315
7 votes
2 answers

Can I access "/data/user/0/" folder in Android emulator from Ubuntu PC?

I am using Ubuntu 18.04. From Android Studio with the following code I am getting file directory Context ctx = getApplicationContext(); final File filesDir = ctx.getFilesDir(); which is /data/user/0/...
mahfuj asif's user avatar
12 votes
1 answer

How to manually root a phone?

I want to learn how to root a android phone manually, I mean without any apps like KingRoot, dr.fone etc. I did not found any guides or information about it. (Background Information: I want to root a ...
NikolaTesla's user avatar
12 votes
1 answer

Storage location of "adb_keys"

I have a Galaxy s3 (I9300) that has a broken touch screen (display is fine). I therefore can not click the authorization dialog that pops up when I try to access the device via adb on any ROMs above ...
davejoem's user avatar
  • 223
6 votes
1 answer

What special privileges "/system/xbin/su" does have w.r.t. root access?

This answer says: Because of the way directory/file permissions are configured on Android, you need to have the su binary on your /system partition in order for it to work. Putting elsewhere ...
Oren Milman's user avatar
4 votes
1 answer

SELinux permissive kernel - is it a security risk?

As in title. I am talking of Kernel, not ROM (plenty of questions dealing with ROM on this site). I have a OnePlus 7 running stock Android 10 and prefer a custom kernel. Of late, OnePlus hasn't ...
beeshyams's user avatar
  • 40.1k
5 votes
1 answer

Access encrypted /data Partition over ADB and recovery (TWRP, LineageOS 16, Redmi Note 4)

I have a Redmi Note 4 (mido) Android phone with a broken screen: the screen lights up, but otherwise it stays entirely "black". I already replaced the screen, but with no luck - the cause of the error ...
x-ray's user avatar
  • 151
2 votes
2 answers

If a user debug build comes with adb root access by default, does it contain the su binary?

If an Android user debug build comes with adb root access by default, does it contain the su binary to achieve this? If not, is it any different from rooting your phone?
Ramesh Joshi 's user avatar
2 votes
1 answer

Missing "Manage root accesses" under developer options in LineageOS 16

My phone is Xiaomi Mi 5s Plus 6GB/128GB. After a clean installation (flashed MIUI 9.6.27 first) of official LineageOS 16.0 Sep 19, 2019, I can't find "Manage root accesses" under developer ...
Jags's user avatar
  • 121
1 vote
1 answer

Adb pull - access denied

I want copy all files(including system files), but when I enter adb pull / i get this: I tried entering adb root but that does nothing. Is there any fix to this? Else any other way to copy all ...
helper's user avatar
  • 285
1 vote
1 answer

Android ADB Key Not Working

I used to have a rooted Android device about 3-4 years ago. I recently found it and I dont know the password. This android device was trusted on my computer but now it is showing unauthorized under ...
Someone Randumb's user avatar
1 vote
0 answers

How to enable USB debugging from TWRP recovery

I have a android device with dead screen. I have installed TWRP recovery for adb interactions while in recovery. I have lineage os 16.0 (Android 9) on my device. I want to access the device screen via ...
newbie's user avatar
  • 31
1 vote
0 answers

Is it possible to bypass the lockscreen using adb without a factory reset?

I found my old htc desire (O2 network) lying in a drawer and decided to boot it up to see what's on it. I seem to have forgotten the lock pattern (at least it doesn't recognise the one's I remember). ...
Bruce Adams's user avatar
1 vote
1 answer

twrp failed to sideload

I tried flashing a custom rom using ADB Sideload in TWRP Now I am unsure how to proceed. I did my preparations: Bootloader is unlocked USB debugging is enabled However when the sideload ...
5th's user avatar
  • 121

15 30 50 per page