Questions tagged [system-apps]

A System app is an app which is placed under /system/app folder in an Android device. As /system is read-only, such an app cannot be uninstalled by an "ordinary" user.

Filter by
Sorted by
Tagged with
4 votes
1 answer
31k views

What is this "com.android.backupconfirm"?

What is the package on my phone that is called com.android.backupconfirm? I tried Googling and found an answer on a random forum that said that is the UI for the backup confirmation dialog. While this ...
7 votes
3 answers
16k views

Is is safe to remove the stock email and calendar app on Cyanogenmod or AOSP?

Is it safe for me to remove the stock email and calendar applications on from Cyanogenmod ROM? I'm using Gmail and Google Calendar so I don't have need for the stock ones. I could simply disable them ...
75 votes
4 answers
203k views

Enable and disable system apps via ADB

Is there any adb command to enable/disable a system app? Thanks
  • 853
0 votes
1 answer
445 views

force stopping of a preloaded app on kyocera rise

Can i press force stop on preloaded app on device by pressing on force stop? Would it free internal memory by doing so? i realize that the preloaded device apps cannot b uninstalled however If i ...
  • 11
1 vote
1 answer
140 views

What Could Cause System Apps to Run that Are Not Used

When testing a widget I created, I wanted to make sure that it uses as little CPU power as possible. After some research I downloaded Watchdog to use as a monitoring tool, which works great. When I ...
  • 113
1 vote
2 answers
2k views

People app disappeared from apps on Nexus 4

It's a system app, but somehow I disabled it. Now, it won't show me my contacts or anything. If I try to see a missed call from notification drawer, it leaves me at home screen. I cannot view any of ...
0 votes
1 answer
883 views

How to disable system apps, or controll which apps launch automatically?

I've been having this problem where the Navigation app launches every 10 or so seconds. I've heard this is because some pins are short-circuited. I've tried to install 2 apps that should make this ...
0 votes
1 answer
4k views

Android does not boot because of missing apk files in system/app folder

I moved the question from https://stackoverflow.com/q/15872848/1665807 I have a rooted Huawei u8825d phone.I want to know if there were no apk files in "/system/app/" folder. So,I moved these apk ...
  • 103
8 votes
2 answers
7k views

Install DSPManager on a non-CM Rom

I would like to install the app DSPManager from Cyanogenmod on my Nexus 4 running ParanoidAndroid. I grabbed the newest CM and extracted "/system/app/DSPManager.apk" and "/system/lib/soundfx/*" and ...
  • 1,087
7 votes
3 answers
3k views

Can SwiftKey be moved to the system partition?

I want to move the SwiftKey app from my standard user partition to the system partition (I have root). I am able to use Titanium Backup or Link2SD to turn an app into a system app, but anytime I try ...
  • 5,367
3 votes
3 answers
60k views

Will factory resetting wipe/clear away pre-installed apps?

I linked my Gmail account to my tablet and I longer want it linked. I have read that it is permanently linked, and I must factory reset the device to unlink the account - is this true? Will factory ...
  • 59
0 votes
1 answer
766 views

Should I backup .odex files too?

I have recently got an app that permits me to view the contents of my phone memory on my rooted Samsung Galaxy Y mobile phone. In /system/app folder, I see all the system apps that came pre-installed ...
user avatar
4 votes
1 answer
210 views

Differnce between abilities of System apps, Apps in phone memory and Apps in the SD card [duplicate]

Possible Duplicate: What are the differences between a system app and user app? What is the difference between abilities of System apps, Apps in phone memory and that in the memory card? The ...
user avatar
11 votes
1 answer
9k views

How do you disable system apps in Android 4.x.x (and up)?

I heard you can "freeze" or "disable" system apps starting in Android 4.0 without rooting. How do you do it?
  • 1,267
34 votes
4 answers
100k views

How do I properly install a system app given its .apk?

I removed a system app (com.android.mms) and I have the .apk needed to restore it, however it won't install through the standard channels (running the .apk gives me "application not installed"). What'...

1 2 3 4 5
6