2 of 5 added 240 characters in body

How to fix failed CM install on moto g?

I have tried to root my moto g, which had the bootloader unlocked, and was on 5.1 GPE to install CM 11.

I have had a lot of issues...

First I successfully installed the CWM recovery, when I went into it it was flickering for some reason. After a reboot the recovery was even gone.

Installed it again, booted into android, put the cm file into storage, went back into recovery, installed it from there. I did not do a format first because it would have deleted the cm file as well...

cm-11-20140504-SNAPSHOT-M6-falcon

So CM installed, upon boot, the cyan logo was flickering, then it was encryption unsuccessful and had to restart, after many restarts it was the same...

Now I have not access to the storage so I cannot even put on another rom, and the installed rom does not start. No idea what to do.

I tried some other recoveries (as that's all I can do at the moment) all of them flicker.

twrp-2.6.3.1-MotoG4.4.img
philz_touch_6.58.7-falcon.img
cwm-6.0.4.7-MotoG-GPE-4.4.img
clockworkmodrecovery.6051.falcon.img

Any help appreciated.

solution

I side loaded a stock rom : http://forum.xda-developers.com/moto-g/development/rom-stock-motorola-lollipop-rom-t3017510

But before I did so, there was a f2fs <> ext4 setting I enabled in philz touch. Now its working well.