4 of 5
formatting
xavier_fakerat
  • 9.2k
  • 6
  • 30
  • 86

SOLVED : External SD card error : java.lang.IllegalStateException : No suitable external storage

I have a Motorola Moto E LTE 2015 (XT1524) (surnia) and a Lexar micro SDHC card 1000x 32Gb.

I followed this how-to install-link2sd-apps2sd-marshmallow, to put my apps on the SD card.

  1. I split my SD card in 2 partitions for external storage:
    • 1st partition in fat32, primary, about 15 Gb
    • 2nd partition in ext2, primary, about 15 Gb (ext4 gives me corrupted partition in my phone, partitionned with aParted on my phone or Gparted on my PC (Kubuntu 16.10), I've tried both, same results.)
  2. My device is rooted, with TRWP 3.10, LineageOS 14.1-20170414 and SuperSU-v2.79-SR3 installed.
  3. I used Apps2SD, and Link2SD, to install apps on my external storage SD card, but it doesn't work and I have this same error:

No suitable external storage

Do you think it comes from:
- LineageOS,
- kernel,
- partitions' softs, flags, labels
- Apps2SD/Link2SD,
- SD card
- ...

And how to fix that ?

Thank a lot

Device Details:
Phone: Moto E LTE (2nd gen) - XT1524
Android version: Android 7.1.1 - LineageOS 14.1-20170414-NIGHTLY-surnia - API LineageOS Guava (7) - bandbase M8916_2020629.41.03.21.51R - kernel 3.10.49-MPI24.241-2.35-1-g1ec3abb



EDIT

Solved.

Shakespeare's language isn't friendly for me and I didn't understand very well the difference between "Move to SD card" and "Link to SD card"

Instead of use "Link to SD card" , I used "Move to SD card" option with Link2sd or Apps2sd softs.
And, as I defined the SD card partition to use as the 2nd ext2 partition, I think the "Move to SD card" didn't find a 1st FAT partition and gave me this error:

error : java.lang.IllegalStateException : No suitable external storage

Lastly, the "Link to SD card" option with the 2nd ext2 partition works well.

I do apologize for the inconvenience.

brochignac
  • 11
  • 1
  • 1
  • 3