1 of 2

I would simply turn off email sync for those accounts specifically. You can do that by going to Settings -> Accounts and sync, selecting the account, and unchecking Sync Gmail. You can still check mail manually through the GMail app, of course.