10

I fixed it! The trick was to clear the cache and data for Google Keyboard. Settings => Apps => ALL* => Google Keyboard => {Clear Data, Clear Cache} * Be sure to go to ALL instead of RUNNING. The instance under RUNNING will not give you the correct data clearing options.


9

Long press on the word when you type it and see it above keyboard. You will be given an option to delete it from learned words. Android 4.3


8

The stock keyboard in Jelly Bean (4.1 or 4.2) does not support multiple languages simultaneously. However, SwiftKey, a third party keyboard, supports advanced predictions with up to three languages simultaneously. SwiftKey Official Website SwiftKey on Google Play Note that SwiftKey is a paid app. You can find the non-trial versions of the application in ...


7

I have a Nexus 4 from T-Mobile, the Google one, with Android 4.2.2. I've been noticing this same problem, and the fix I found was to go to Settings -> Language and Input -> Then press the settings icon next to the Google Keyboard (English, U.S.) option -> then deselect Block offensive words. I can now swype swear words, although often times it is not the ...


5

Check your contacts. Keyboard will search and suggest contact names.


5

When you type in "don't" try holding your finger on "Dont". You should get something along the lines of: Never predict "Dont" again? Press yes, and you should be sorted!


4

Actually this feature does exist, but it is disabled by default, so to enable it in a vanilla Android Jelly Bean 4.3 you must follow the steps below: Open your Phone app, tap the dialer tab (first one at the left). Tap the action overflow icon (at bottom right corner) and tap Settings Scroll down to section Other call settings. You'll see the option Dial ...


3

This is a strange solution but it seemed to work (tested on Android 4.4): go to System Settings scroll to Accounts section click Google under Privacy section, click Search under Search & Now Cards section, click Accounts & privacy scroll all the way to the bottom and click Search engine storage click Clear now Try typing one of the words you didn't ...


3

You have to turn off the keyboard trace. Unfortunately through a very poor design, you can't have trace without the autocomplete.


3

It depends on what keyboard app you're using. If you're using Google Keyboard (the default on Nexus devices), go into its settings. Go to the Text correction section and click Auto-correction. Choose Off from the list. If you prefer, you could install a keyboard that supports using multiple languages at the same time, such as SwiftKey.


3

Go to setting ---> Controls ---> Language and inputs ---> keyboard and input methods --> (setting icon) behind your keyboard type -- > predictive text --> clear personal data .. :) That's all :)


3

Several people didn't read the original post. The original poster had tried long-pressing the word to get it to delete, but that didn't work. I know this is an old thread, but I just found it because I had the same problem. I just fixed it by using an idea I got from one of the previous answers. I could delete some words, but not others. I think that you ...


3

I just figured it out while trying all possible Gboard settings. Turns out that "block offensive words" was activated for some reason, and apparently the word "hon" is considered offensive in some places. I had no idea it was an offensive word, and either way I'd have thought Gboard was clever enough not to block english offensive words when I'm in "swedish ...


3

The same problem happened to me a few days ago, which was resolved thusly : Go to the keyboard settings : Settings>Language and Input>Virtual Keyboard>Samsung Keyboard Check that your languages are selected in 'Languages in types' Make sure that the "Predictive" option is activated. Make sure that the "Auto replacement" option is activated. Restart the app ...


2

Menu >settings>apps>running application>find Xperia keyboard >settings(xperia keyboard)>text input settings>my words,..choose the word you want to delete or edit,,.. Thats the step that I learned so far ,.,hope helps..


2

Swiftkey allows for disabling of the auto-correct when a physical keyboard is being used. To Disable Auto-correct during physical keyboard use: Open Swiftkey's settings Open the Swiftkey app from your App Launcher Long press on the Swiftkey Logo/123 button when the Swiftkey keyboard is up Go To Advanced Scroll to the bottom Check the option for Physical ...


2

SwiftKey simply is a keyboard app. You might want to check in Settings→Language & Input→Keyboards and Input methods which keyboard is active/checked, and check its configuration. Many keyboard apps allow to turn off autocorrection: so does the default keyboard on my Wildfire (running CM 9.1/Android 4.0.4). If your keyboard does not support ...


2

User Dictionary Manager might be what you are looking for. From the description: UDM is an application that allows you to edit/export/import/delete/clean the user dictionary words found on your Android phone.


2

I had exaclty the same problem. I use Sony Xperia Z with Jelly Bean 4.3 The solution that worked for me is like this: 1. Stop contact autosync of google account. 2. Clear all data and cache of Contact Storage App. After this Email app will not autocomplete with Gmail contacts. The drawback is that the native Gmail App will not autocomplete either. In ...


2

I don't know how to use them simultaneously, but yes, you can have 2 languages. Make sure the second language is installed under settings. Then under keyboard make sure you tick the setting an extra key should appear when using multiple languages. Then when you are typing, let's say in whatsapp or so, go to your menu and tick the box of the second (installed)...


2

When the suggestion is shown above the keyboard, just tap and hold on that word. It will give you the option to delete it. You don't need to clear the complete database just for that!


2

Best bet would be to check System settings > My device > Language and input > Samsung keyboard (gear icon) > Predictive text (make sure this is on / green). You might want to check on the Learn from (word) items there.


2

My problem was with the word "too", i had spelled it "t p o" with a "p" in the middle. And i couldn't hold my finger on it till it gave the option to remove it. I kept typing it incorrectly a few times till it showed up in my recently used words, the words that show up on the list above the keyboard when i haven't started typing yet and the cursor is just ...


2

You can change the words in the user dictionary by going to Settings > Language and Keyboard > User dictionary. From here you can edit as you wish. There is another way mentioned here that may be easier for you: How to remove misspelled words from your Android Dictionary "Maybe this is more obvious to everyone else, but the dictionary is accessible from the ...


2

I'm afraid that is not possible for the stock LG keyboard on the LG G2. You can only edit words that you have added yourself using Jimmy's method above (or below?), that is, words in the personal dictionary; but you cannot delete words that came with the standard dictionary. Sadly tho came with Lucky Goldstar's stock dictionary. At any rate, I commend you on ...


2

I managed how to disable the Lollipop's spell checker, (not one from keyboards as in other answers). Just go to, Settings → Language & input → Spell checker then switch it off. Already done ;)


2

This other SE answer might be of help if your phone is running under CyanogenMod. That answer, in turn, points to this article where author shows the location of built-in dictionaries on the phone filesystem, as well as the location of built-in dictionary source files in Android open source project. The rationale (all to be tried) should be grab the source ...


2

The keyboard also has a language setting, that can be different from the phone. Go to (Settings > Language & imputs > Language > LG Keyboard > Input Language and type) Select your preferred language (English) and keyboard type (QWERTY)


1

The thing that worked for me was downloading and using English (UK) as default.


1

If it is auto-completed by Google Chrome, please follow the following steps, Go to your Google Account Dashboard. This will list all of the information collected on you by Google. Scroll down to Web History and search for your Credit Card entry or other entries to be removed, and remove it from the history. Or you can go directly to your Web History. ...


Only top voted, non community-wiki answers of a minimum length are eligible