7

I have the same options on my Nexus 6P as I did on Nougat however, they are accessed slightly differently. If you click the 'Do not disturb' text in the notification panel you should see the options you're after. I get the 1 hour option and (when within 12 hours of an alarm) the option to turn off at next alarm. This article on Ars Technica demonstrates a ...


4

This is most likely caused by a setting that's intended to reduce battery and service usage by turning off your data and/or wifi connection while you're not using the phone. There's a few settings you should toggle: 1: Settings -> Power -> Sleep Mode This is on by default and causes the device to turn off the data connection during longer sleep ...


4

I can see in Google's documentation for the Pixel that the feature that lets you set how long DND mode should last (15,30,60.. minutes) is there in the Pixel, just as it was in my old Sony Xperia: https://support.google.com/pixelphone/answer/6111295?hl=en Unfortunately it looks like Samsung removed this feature with their Touchwiz overlay, so you're only ...


3

As you guessed, you need an extra app and in this case automation app. MacroDroid is easy to learn and free up to 5 macros. You need one macro Trigger Bluetooth event → Device connected → your car device Action Priority mode/Do not disturb → select one of the options - Allow priority notifications or Block all Name and save the macro ...


3

The Do not Disturb setting is easily accessible in the notification panel on most Android devices. To find it on a Galaxy S9+, using two fingers, swipe from the top of the screen, and you'll see all available quick settings. You should see DND mode as one of the option. (If it's not there, swipe the screen to the right or to the left to find it) Tap on the ...


3

On stock Oreo 8.0 (MiA1) Settings → Apps and notifications →App Info → Choose app (not all apps have this permission) →App Notification → Enable override


3

It seems like an Oreo issue as documented here: https://www.androidpolice.com/2017/09/26/feature-bug-oreo-dnd-turns-off-get-barraged-sounds-vibrations-pending-received-notifications/ It was resolved in 8.1.0, but Samsung hasn't provided this update to its 8.0 phones. So today it is mostly Samsung users that are affected. https://us.community.samsung.com/...


1

I checked this about an year ago when I had hangouts installed All messages (including text) that use GCM were blocked. WhatsApp doesn't use GCM so they will be received


1

Samsung phones Samsung's website has this article: How do I block unknown or hidden numbers from calling me? Here's how you enable this feature: Open your phone app. Tap the three dots icon, or the "more" icon. Tap "Settings" Tap "Call rejection" or "call blocking" (you can skip this step on some phones) Tap "Block numbers" or "Auto reject list" or "Block ...


1

Android 4.4. there is such a function. in the curtain. convenient, beautiful, functional.


1

Caveats OP is willing to reject unknown numbers in weekends They have their office contacts and private labeled in their address book Only office people call on office SIM , they are not aware of private SIM number and vice versa for private contacts They can continue to use data from Office SIM Not tested on dual SIM but should work I don't think it is ...


1

This is usually caused by applications such as peel remote. As a solution try disabling the application. Try disabling the app: To disable an app, go to Settings √ Apps √ Applications √ Peel Smart remote then choose option. Alternatively deactivate it in drawer; Go to the app drawer, tap Edit, you will see minus sign besides the given app at the top-right ...


1

DND is not a cron job... It's "embedded" in the OS databases. Unless someone knows exactly what file and where, assuming it's ASCII editable file, a factory reset might be your only option.


Only top voted, non community-wiki answers of a minimum length are eligible