21

Gmail 5.0 added support for Exchange accounts, but it requires an additional APK (Exchange Services) which you can't get from the Play store unless you already have it. As one of the other answers indicates it seems to just be with Nexus devices at the moment (maybe some newer Lollipop ROMs do for other devices, not sure). However, you can sideload it! I ...


9

First off, talk to your Exchange administrators. See if they deliberately are setting the mobile device security settings so tightly. I would have a discussion with them to see if they can loosen up the security settings. If you only want email you could try K-9 from the app store. It uses IMAP to get the mail from the server so your exchange server will ...


8

A co-worker said he found a work-around with this app: Moxier Mail. I'm using the trial right now and I like it a lot. I really like that it lets me separate my work from the rest of my tablet. It also doesn't fall under the security requirements. It does require a pin for the app itself and there are useful widgets. All-in-all it seems even better than the ...


7

No, they are not. For as long as you have the account registered in your email app, the policies are applied, however, if you remove the email account then the policies will no-longer be enforced. The app is given a "device administrator" status (you can see any apps which have this in "Security" in your settings), and you can revoke that at any time. ...


7

I highly recommend MailWise. It has an Exchange override that allows you to turn off the server's influence over your device. Use it at your own risk (your employer may get whiny about it) but I can say it does work very well. In order to use the Exchange Security Bypass, you'll need to go to MailWise's FAQ and follow the instructions. You basically just ...


6

I have the same issue, N7 with 4.2 with an Exchange Corporate Account that forces a password/pin. You are correct that it has to do with corporate account. I removed my corporate account and was able to add widgets, even with the security still set to "password to unlock". I also changed to Pin and Slide to unlock and all of them worked as well. I then ...


5

Here it is the modified Email.apk. (This is for Ice Cream Sandwich 4.0.1 Only! ) This tool bypasses security restrictions (the client claims it will enforce the hard reset policies but it won't in fact). Please use it with extreme caution. There is a specific reason why an administrator configures such a policy, and I would recommend it to everyone. If ...


5

I know of three alternative mail/calendar/contacts apps that can get you around the Exchange security policies assuming that you cannot have the policies turned off and you do not have IMAP/SMTP access: Microsoft Outlook for iOS/Android (free) - I personally use this for all of my email accounts now and love it. It has cloud storage support (Dropbox, Google ...


4

K-9 Mail supports Exchange 2003/2007 via WebDAV. No support for Exchange 2010, unfortunately, since Microsoft removed WebDAV support in the newest version. See the official wiki page for configuration instructions.


4

As with most Exchange ActiveSync clients Android implements a sub-set of features from various versions of ActiveSync. According to the Android 4 (Ice Cream Sandwich) Platform Highlights, the Email client supports EAS v14 (scroll down to the "Improved email" section), in a comparison with Gingerbread (Android 2.3.x) though you also need to take into ...


4

This isn't very elegant... Open the Android Contacts app Menu --> Display options --> Choose contacts to display Under each account, expand the list, make a note somewhere of what was checked, and then uncheck everything Tap Done. You should now be left with phone-only contacts Menu --> Import/Export --> Share visible contacts You will see some ...


4

I think I have encountered a similar issue before. Not sure how I fixed it, but see if you have a Device Administrator for Exchange. In the Samsung Galaxy S4, it's in Settings > More > Security > Device Administrators. Uncheck / Remove it there, do a restart, and see if that helps. or: Go to your application manager, and swipe to the ALL section. ...


4

No. You can only do what you describe on Samsung devices with their "KNOX" feature. This uses special security hardware to provide separate, isolated environments on your phone, so there's no way that information can leak from the "business" environment to the "personal" environment. It's present on their high-end phones since the Galaxy S3, and you can ...


3

I was just suffering from the same issue with an Exchange 2010 server. The problem was server-side not client-side. Upon investigating the event log for the Exchange role, I noticed the following error entry: Exchange ActiveSync verfügt nicht über ausreichende Berechtigungen zum Erstellen des Containers "CN=Oliver Salzburg,OU=..." unter dem Active ...


3

There's 2 slightly different solutions. Log onto your corporate mail account using Outlook Web Access. Go to the account settings, i.e. the options link. Under that, select Phone, and delete your phone profile from there. Now delete & recreate the Exchange account on your phone, and this time don't choose to sync contacts. Exchange has a corporate ...


3

Not sure if you've made any headway on this. I was searching for answers for this today and got it figured out. I've got a Galaxy S4, running 4.2.2 I had to open the native email app. Menu > Settings > Exchange Account with sub folders > More Settings > Folder Sync Settings. From there I think it should be self explanatory. Not sure what ...


3

Unfortunately the native Android Exchange Client doesn't support automatic sync of sub-folders, as you have seen you can go in to the folder and sync it manually but that isn't much use. This hasn't been improved much in Android 4.0 Ice Cream Sandwich. The sub folders now sync but it doesn't notify you of new messages in them which isn't really any better. ...


3

With Android 6, this is still an issue. You can remove the contacts by clearing the data from your "Contacts Storage" system app, but this will unfortunately also remove any locally stored contacts. If you use another account for your contacts sync that runs after deleting the contacts data, this might be a solution for you. I've written a blog post with ...


3

Messed around with it a bit more and found a solution. I just had to go to Settings -> Accounts & sync to delete the Exchange account.


3

There are many ways to sync your Exchange contacts to Gmail. The easiest way is to do this on your computer. This involves exporting your contacts from Outlook into a CSV file, and then importing that file on https://mail.google.com site. Export your Outlook contacts to a CSV (Comma Separated Value) file. Steps to do this vary for different Outlook ...


3

Your "local and private" Android calendar is your Google calendar. When you've created that personal event it defaulted to your Exchange calendar. In order to avoid this is the future make sure that you create events in the calendar you want to. Usually it defaults to the last calendar you've created an event in.


3

It's in the settings for your Exchange account, hidden rather well. Go to: Settings Accounts Exchange Settings Select your Exchange account More Settings Uncheck "Sync SMS"


3

It turned out to be a sync error for some contacts with malformed birthday field created on Android which causes exchange to silently fail. You can debug it, by getting the Exchange server-side logs, by going to your Exchange Webmail (Outlook Web Access, OWA): Login in to webmail.yourdomain.com go to: Options -> All options -> Phone mark your current ...


3

First try clearing the app data of the stock email app in settings->apps, if that doesn't work: If you go to settings->apps again and click on the stock email app (not gmail) then click disable, that should do the trick. However: If you still have a non-gmail email you could try lowering the sync frequency from push to every 30 mins.


3

I was able to get around this by putting in an invalid email address on the first step (e.g. myname@mydomain.com.exchange) then clicking the button to set up the account manually. I wanted to set up an Exchange account and was able to enter my proper corporate credentials in the following steps. This seems to have worked.


3

Try the Mail Wise app. It bypasses Exchange security, but you won't be able to use the Gmail app. For details, read this Mail Wise FAQ.


3

On the new Samsung Galaxy S7 - You must delete the account receiving the text messages and then reinstall it. During new account set up is the only time you will see the option of whether to sync SMS. It does not appear anywhere else once you leave the initial set up screen. Once the account is installed, you will see options for syncing email, contacts, ...


2

This happened repeatedly to me, I'm not entirely sure why. What worked for me was to do a "Clear data" (in the Applications screen) on the Email app. When I recreated the profile the next time, it stuck. It may not work for you, but it's worth a shot.


2

Step 1- Be sure sync is on for your other contacts (Google, for example) and that it has been synced so you don't delete contacts you've added to your phone as well! Step 2- De-active contact sync for your Exchange account: Settings > Accounts > Exchange > [Your Account] > Contacts to Off Step 3- Clear the previously synced contacts by clearing the ...


2

Well. First, I deleted my Exchange account. Then I was able to change the screen lock settings and the change would be displayed in the settings page, but when I locked the screen, no PIN or pattern was required to unlock. Then I power cycled the phone. After that I was able to successfully use Screen lock settings. Then I added back my Exchange account, and ...


Only top voted, non community-wiki answers of a minimum length are eligible