6

Not all phones support hotword detection being on all the time (i.e. "OK Google" from any screen). The phone needs a lower-power co-processor, to avoid running down the battery by keeping the processor running at full power all the time just processing sounds. It's up to the system integrator (the people who compile Android for the phone) to set whether this ...


4

After searching around, this appears to be an issue with SlimKat ROM itself. Reading this review of SlimKat or alternative link to article as their formatting is awful, the line that jumped out at me was: ....talk to by simply saying "Okay Google" (sometimes even just okay-_-) suggests this happens on the ROM. Also there is a theory that the launcher ...


3

"Ok google, set alarm label laundry for 20 minutes"


2

Unfortunately, as of this writing it is not possible to set a timer and a label with an OK Google command. OK Google only supports the basic "set timer for x-amount-of-time" and no additional parameters, you could however use the "reminder me to ..." command to have comments/labels as an alternative for short term items or use the "create a calendar event ......


2

Under Security and under Smart Lock, go to Trusted voice and check the option that says Always on. That's how I got "OK Google" to work when my phone is locked. I use the fingerprint lock as well.


2

For this to work, your Nexus 5 will need the "always listening" mode. It's not supported on this handset officially, but there are community developers working on enabling this feature. As of this writing, the development is still in a (semi-)working proof of concept stage.


2

Well, I'm a couple years late, but "set timer called 'name' 'duration'" works (most of the time).


2

I believe this website has a guide to the solution that you're looking for. Edit: I was asked to summarize the site (Yes, I did just copy and paste the instructions for the most part): Google Now has a neat ability to listen for the “OK, Google” command to automatically launch the app and get you into Search as fast as possible. But, you may not want ...


1

"certain devices" = devices that meet the requirements (eg. android version) Now to your problem. It could have many reasons. I assume it's a bug in the Google App. The Samsung Galaxy S6 had the same problem after a system update because of battery saving settings. Google fixed that. I suspect that some battery saving related settings changed with the ...


1

Please update your default System language as English(US). It must work as Ok Google now supports only that. Go through this link "OK Google from any screen missing!"


1

Make sure "ok Google" detection is on for every screen. Do this by opening the Google app, navigate to settings > voice > "ok Google detection" and make sure the "from any sceen" option is enabled. Hopefully this solves your problem.


1

I figured out a way. I uninstalled the updates of the google app in my device and re-installed the latest version from the play stoore. Then the text appeared. Once I activate ok google detection form "any screen" the text disappears.


1

It's not the best method but if you happen to use Nova Launcher you can make a widget that gets to the Voice Command Preferences (which is just one click away from accessing the detection settings). Long-press on the home screen (with Nova installed) Click Widgets Place an Activities shortcut somewhere on your homescreen. Scroll down to the Google App ...


1

"Thank You." Seems to work. It will stop listening, but also will pop up a list of Ok Google commands. Which is annoying and unneeded. Personally I just say"open (last app)" and resume my life.


Only top voted, non community-wiki answers of a minimum length are eligible