4

Try going into Settings > Language & Input and configure the Google Keyboard. In there you can turn off 'Auto-correction'. This should stop it from changing the foreign words to English. You could also try adding additional dictionaries. This should allow you to enter words from different languages without it detecting them as mis-spelt English words.


3

The following is the way I enable additional spell checkers on my Galaxy Nexus which runs on vanilla Android 4.3, I hope it will be the same for your Moto G: Open your app drawer and go to Settings > Language & input Scroll down to Keyboard & Input Methods section: If your Google Keyboard is enabled, tap its settings button, if not, enable it first. ...


3

Go to the Play store, and install Google Keyboard. This includes its own spell checking dictionary. Navigate to: Settings -> Language & Input -> Spelling correction And select "Google Spell Check". You can click the settings icon to change the language too.


2

I researched on Fleksy Keyboard and there's not Spell checker for disable it. so, Goto -> Android Settings -> Language & Keyboard -> Touch Input -> Text input -> Spell correction or, on Lollipop : Goto -> Android Settings -> Language & Keyboard -> Spell checker and then, turn it off How to turn off red-dotted-underline ...


2

I managed how to disable the Lollipop's spell checker, (not one from keyboards as in other answers). Just go to, Settings → Language & input → Spell checker then switch it off. Already done ;)


1

Are you sure you enabled USB debugging on your phone? Is your phone listed when you enter "adb devices" in cmd? When you connect your phone to your PC, your phone should ask for a confirmation to start USB debugging. The problem I had with these instructions was that my phone didn't actually connect to my PC, so ADB did not recognize the device. After ...


1

On the Galaxy A 5, go to : Settings -> Language and Input -> Samsung Keyboard Settings -> and switch "Predictive text" to off.


1

I had exactly the same problem - only words from Contacts shown on spellcheck line. I downloaded Google Keyboard and altered Settings as suggested but it didn't make any difference. However, when I ran Google Keyboard from the icon and selected "use Google Keyboard", everything magically started working. This post was corrected throughout 100% correctly. ...


Only top voted, non community-wiki answers of a minimum length are eligible