8

The stock keyboard in Jelly Bean (4.1 or 4.2) does not support multiple languages simultaneously. However, SwiftKey, a third party keyboard, supports advanced predictions with up to three languages simultaneously. SwiftKey Official Website SwiftKey on Google Play Note that SwiftKey is a paid app. You can find the non-trial versions of the application in ...


3

The same problem happened to me a few days ago, which was resolved thusly : Go to the keyboard settings : Settings>Language and Input>Virtual Keyboard>Samsung Keyboard Check that your languages are selected in 'Languages in types' Make sure that the "Predictive" option is activated. Make sure that the "Auto replacement" option is activated. Restart the app ...


3

I just figured it out while trying all possible Gboard settings. Turns out that "block offensive words" was activated for some reason, and apparently the word "hon" is considered offensive in some places. I had no idea it was an offensive word, and either way I'd have thought Gboard was clever enough not to block english offensive words when I'm in "swedish ...


3

The following is the way I enable additional spell checkers on my Galaxy Nexus which runs on vanilla Android 4.3, I hope it will be the same for your Moto G: Open your app drawer and go to Settings > Language & input Scroll down to Keyboard & Input Methods section: If your Google Keyboard is enabled, tap its settings button, if not, enable it first. ...


3

If you're using the stock Android keyboard, you can report it on the central Android bug tracker. Be warned that there are already more than 25000 reports there, and many never receive any response from Google. If you find a bug in a third-party keyboard you're using, visit the keyboard's page in Google Play (either through the Play Store app or on the ...


2

I don't know how to use them simultaneously, but yes, you can have 2 languages. Make sure the second language is installed under settings. Then under keyboard make sure you tick the setting an extra key should appear when using multiple languages. Then when you are typing, let's say in whatsapp or so, go to your menu and tick the box of the second (installed)...


2

here you would find the same issue: http://forums.androidcentral.com/sprint-samsung-galaxy-s4/364298-samsung-galaxy-s4-keyboard-can-t-remember-added-new-words.html The solution is in the same post. I would cite it here: I think I may have found a solution. I recently had the same problem w/ my samsung galaxy s4 Active. I went into settings. I then hit ...


1

You can try this if you are using stock Samsung keyboard: Go to Settings >> Language and Input >> Virtual Keyboard >> Samsung Keyboard >> then add your other language (you may need to download). or Settings > General Management > Language and Input > Virtual Keyboard > Samsung Keyboard > Add your other language. (may depend on android version) ...


1

I have found a app that may fix your issue: SwiftKey by Microsoft. It is a beautiful keyboard that supports bilingual autocorrect. Get it here


1

Thank you, but the suggestion above didn't work for me since I already had the 'block offensive words' disabled. However, I found out that for Gboard to learn the words I typed, I also had to enable the 'personalized suggestions', under settings > text correction. Hope this helps :)


1

Xperia: you can hold on the word displayed and u have an option to delete it. You can add words by going through 'language & input' then add your words in 'personal dictionary'. I would like to edit from a 'list' of saved words but I haven't found my way to the list.


1

This is how I solved this problem on my HTC One: Go to Settings-> Languages and Keyboard. On this list is a "Swype" setting that shows it's set to "Swype". Not informative. But press your finger on it anyway. Bam! The most useful menu that I never knew existed appears. You can add a language that will be in use simultaneously with your primary ...


Only top voted, non community-wiki answers of a minimum length are eligible