5

Thanks to Daylight Savings Time (DST) I have run into an issue. I live in Arizona where we don't participate in DST. I'm using the default calendar app that came with my phone. I have an outlook.com calendar that I sync between my phone, my desktop (Outlook 2007), outlook.com (the cloud) and my wife's phone. It has been working great until DST hit yesterday. Now all the Outlook appointments have shifted one hour.

In reading up on the issue it seems that Outlook relies on the computer's time setting to handle the time zone and creates its appointments with GMT +/- your time zone (so for AZ, it's GMT-7) rather than specifying the time zone explicitly (i.e. Mountain Standard Time - AZ). When another computer gets it, it looks at their time zone information on the recipient computer and adjusts accordingly (oh, AZ computer that's GMT-7 and NO DST adjustment). The problem is that the calendar app on the phone (and the new Google calendar app) just read the GMT-7 and then make the DST adjustment, but never factor in that we're AZ which get's no adjustment. So, it changes it to GMT-8 rather than leaving it at GMT-7. If I create the appointment on the phone, I can set the appointment to be GMT-7 (AZ) which then will display correctly across all devices, however I don't always create on the phone.

Is there any way to have the calendar(s)/the phone stop using DST altogether? DST doesn't apply to any of the calendars I have on my phone and I don't see it applying anytime in the future either. (I tried the new Outlook App for Android, but it's still beta - really beta).

I have an Motorola Moto G with Android 4.4.4

  • On Both my Android devices, the Timezone list has an intentional TZ for Arizona, along with a Mountain TZ. Is the proper one selected? Do you have 'Auto Timezone' selected as an option? If this is the case, it is not the device in error, but the interpretation of the TZ Broadcast you are picking up. Windows, your computer, also has an intentional Az TZ. Is the correct one selected there? – wbogacz Mar 9 '15 at 20:20
  • 1
    On the phone under setting, Date and Time, there is a setting for "Automatic time zone". If I deselect this option, I can select 'Arizona' which selects GMT-7, Mountain Standard Time. I did this when I first got the phone and it still behaves incorrectly. Windows is also set correctly on the desktop. – yougotiger Mar 9 '15 at 20:45
  • 1
    Which calendar app are you using - if you are using the Google calendar app, perhaps it is syncing back to Google and screwing up the settings - so check your Google account. Also in the Google Calendar app there is a setting for device time zone which is another thing to look at. – Morrison Chang Mar 10 '15 at 3:28
  • I tried the default Android calendar app as well as the Google calendar app. Both of which display the same behavior. Changing any of the settings I've found for time zone hasn't helped. – yougotiger Mar 10 '15 at 13:52
1

I had the same issue on my S4 and finally got it fixed. This is what I did:

  1. Delete account credentials from phone
  2. Delete all data from calendar and email app
  3. Reconfigure account credentials
  4. Sync calendar and emails

After that all calendar events were showing up correct for AZ time zone.

1

The answer I finally settled on was to use a different calendar app. The Android app (even after an OS update to Android 5.1, and an update to a new version of the Android Calendar app) still has this issue. I'm currently using the Microsoft Outlook app and have had no issues with DST changes. My recommendation for people with the issue is to get a different calendar app. This has been a know issue for several years and Google hasn't addressed a solution for it.

1

Set the timezone manually irrespective of DST. Go to Settings -> General settings. Enable "Use home time zone". At the Home time zone setting, type "GMT-X" where X is your timezone, scroll to the bottom, select the desired timezone.

Just remember to change the timezone for DST.

EDIT: Also changes the current time perceived by the calendar application, so this does not work.

0

Turning off daylight saving handling likely will just makes things worse. You don't want that.

For calendar calculations to work, you need to have these things set up correctly:

  1. The computer's system timezone is set up to the correct local time zone and has an up to date timezone database
  2. The phone's system timezone is set up to the correct local time zone and has an up to date timezone database
  3. You created the events with the correct time zone
  4. The format conversions during calendar synchronization are implemented correctly

Now all the Outlook appointments have shifted one hour. ... If I create the appointment on the phone, I can set the appointment to be GMT-7 (AZ) which then will display correctly across all devices

That is indicative that your events are created in the wrong time zone. You should fix the timezones used in the events and fix the settings of the program that created the incorrect events. Giving the timezone might mean that you'll have to shift your existing events en masse.

  • Outlook doesn't create it with a specific time zone, rather with GMT+/-X. This is kind of where the problem lies. The outlook App for android will get the appointments right on the phone, it's the other calendar apps that are shifting the appointments (android default and Google calendar) despite the phone being set to AZ time zone, they see the appointment with GMT-7 as Mountain Standard Time and then apply DST rather than seeing I'm in Mountain Standard Time, but with AZ applied (as the phone is set) and NOT shifting for DST. – yougotiger Mar 10 '15 at 13:56
  • Can you check and describe the exact system timezone settings on all your computers and devices? Also, describe the steps that you usually took when setting up an event in Outlook when setting the timezone and/or what your settings are for Outlook's default timezone settings. If Outlook really creates the event with UTC offsets, then timezones would never have been applied in the receiving side. It's either the converter doing that or your events aren't actually being created with UTC offsets. – Lie Ryan Mar 10 '15 at 15:02
  • Desktop computer: Date and time settings for Time zone: (UTC-07:00) Arizona On the Phone: On the phone under Settings -> Date and Time -> there is a setting for "Automatic time zone". I unchecked this this option and selected 'Arizona' which selects "GMT-7, Mountain Standard Time." Default Android Calendar AND the Google Calendar available on Google Play: Any appointment created before DST started gets shifted. Microsoft's Outlook App (Beta): appointments display correctly.(Id just use this, but it REALLY is beta) It seems that this configuration would show it's an issue with the calendar app. – yougotiger Mar 11 '15 at 16:08
0

I had the same issue on my Samsung Galaxy S4 which started at the onset of DST. Here's what I did and it seems to work. I turned off the Automatic Date and Time feature, as well as the Automatic Time Zone. Then set my own date and time, which for all intents and purposes was already set, and reviewed the effect on my calendar. Things before today were still off by an hour, but who cares! Things today and in the future I just deleted, then re-entered. Now it looks okay!

0

Device info: Nexus 6p/Android N beta Issue: Calendar sync off by one hour. Desktop Outlook correct/phone calendar one hour later. GMT seems to be set correctly and device getting its time from the network. Solution: 3rd Party app 9 by 9Folders. My preference is simplicity and sticking with the minimum number of 3rd party apps but guessing if my calendar has gone rogue is not an option

  • 1
    Could you add a link to the app you're recommending? How exactly did it solve the problem? – Dan Hulme May 23 '16 at 12:46
  • I used the official Microsoft Outlook app for Android. It's more mature now and working well, they have most of the kinks worked out, and from day one, the calendar didn't have the DST problem. We have several people here at work that we support and they've had the same problem with DST causing issues. In all instances that we've tried it, using the Outlook application alleviated the problem. – yougotiger May 25 '16 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.