This appears to be a duplicate of this post, but the solution there didn't work for me. Clearing the credential storage wasn't even an option -- it's greyed out.

Starting at the beginning -- I started to set up a VPN on my phone (Note 3, Android 5.0) but cancelled the operation halfway through, yet the OS still enforced the security settings (a PIN). I have tried a few things trying to disable the PIN lock, but the only option I have is to upgrade the security to a "password" which is even more unacceptable.

So far, I've tried finishing the VPN setup (it worked) then removing it, also force stop/disable of the VPN app, and quite a few other things that I can't recall at this moment.

I think part of the issue is that a certificate was installed when I started the process, but I have no idea which certificate it was. The System cert list is populated with tons of entries, but the User cert list is completely empty. Is there a way to determine which certificate was installed so I can remove/disable that one? I'm concerned with choosing the wrong one, as who knows what it might break on the phone.

  • Is your phone rooted? Without root, any trace of the installed certificate has to be in the user section. If you have root, you could sort the system certificates by date using a file explorer.
    – gertmenkel
    Jul 1, 2015 at 22:56
  • Phone isn't rooted. If the VPN that I attempted to create was an android function (system/more networks/VPN/etc), would that still have used a user cert?
    – Tim S.
    Jul 2, 2015 at 0:09
  • Exactly: if you don't have root, all user certificates are located in the credential storage, which contains no user certificates like you said. It's like the credential manager somehow has a bad state, thinking there are credentials stored on the device but when if looks for them, it can't find any. Could you perhaps try installing some kind of root certificate? I know for a fact that ca root certificates go into credential storage, so you should be able to reset your credential storage ater installing the certificate. Another type of certificate might work as well.
    – gertmenkel
    Jul 3, 2015 at 2:10
  • Do you have any suggestions for a safe CA cert? Ironically enough cacerts.org got an invalid certificate when I browsed there oh my phone :)
    – Tim S.
    Jul 6, 2015 at 17:14
  • You can try the one from Startssl: startssl.com/certs/sub.class1.client.ca.pem
    – gertmenkel
    Jul 6, 2015 at 17:34

1 Answer 1


Try this Its an apk that can disable the screen lock. It worked for me on KitKat when I had the same problem. Install it, select launcher and don't mind the icon.

  • Not looking to fix this with software.. thanks.
    – Tim S.
    Jul 2, 2015 at 16:19
  • The only other thing I can suggest is disabling all of your device administrators.
    – Snowman
    Jul 2, 2015 at 20:23
  • Oh yeah -- that's another thing that I tried before... still no dice.. Thanks though.
    – Tim S.
    Jul 2, 2015 at 21:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .