I have a Samsung tab2, and have added screen pin lock on my Tab few days back as I was going out. Now I don't want to use pin lock as security, but I am not able to disable it. I am going to

setting --> security --> screen lock

After entering my pin my options are to disable includes last the option None.

What should I do to remove the screen lock pin??

  • Which ROM are you using? Stock or Custom? – Akhil Mar 4 '13 at 9:08
  • Under some circumstances Android forces you to have a PIN or password. This happens, e.g. if you install a custom trusted certificate. Therefore I would check Security settings and there the storage options if user certs are installed. – Robert Mar 4 '13 at 15:45

In my case, I installed my own certificate which even on removing was some where present don't know where so ultimately I cleared up every thing and again tried to remove pin and it got removed.

Proper way would be settings-->security-->clear credential Clear credentials is last option under security heading.

And now u can change your pin setting-->security-->screen lock-->swipe/none whatever you feel comfortable with.

Enjoy :D

  • Not working for me.. I've Samsung S2 – TechArcSri May 6 '14 at 5:51

Go to Settings--> Profiles .
In the profile settings at the bottom is an entry for "System settings-->Lock screen mode".
You can choose several settings, one of which is disable.
You can disable Lock Screen by "disable" option or you can remove PIN by "insecure lock screen" option.


Turned off the screen, turned it back on and clicked on Forgot in the right down corner. Give Google password and it will change Lock method automatically back to slide.

Just try it.

  • Thanx, but that's what I added that, None option is disable in my case!!! – Android Mar 4 '13 at 7:12
  • If you already set a PIN , then there should be a prompt to enter PIN if you tried to change it. Was there any prompt pop-up when you tried so? – Akhil Mar 4 '13 at 8:36
  • yup. As I mentioned in the question after entering pin NONE option is disable. – Android Mar 4 '13 at 8:57
  • Answer edited with solution. – Akhil Mar 4 '13 at 9:22

I also messed around with the lock screen, and only when i cleared all credentials it came to remove the pin protection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.