Device: ASUS MemoPad 7 (K013), running the latest ASUS ROM based on Android Lollipop 5.0 (updated automatically with the included ASUS updater).

When I lock the screen, the system time stops ticking until I unlock it again. After unlocking, it does not update to current time, instead lags behind for the amount of time it was locked.

  • The time zone is set correctly and the device has stable Internet connection via Wi-Fi (no packet data option available on this device).

  • The date/time update setting is set to "Use network time", which disables manual time adjustment. After unchecking "Use network time" I can set the time manually.

Interestingly enough, after adjusting the time and re-enabling "Use network time", the time instantly skips back to the "lagged" value (how it was before manual adjustment).

Rebooting the tablet forces a time update, although the problem keeps persisting on screen lock, which renders the system clock, and thus the device, useless for my purposes.

A similar problem used to occur for me on a different device, but the time was updating automatically a couple seconds after unlocking. This is not the case here.

Please advise.


1 Answer 1


Wiping cache with stock recovery seems to have solved it for me.

Power off phone (be sure to turn off fast reboot in settings first). Boot into recovery by holding volume-down key and then holding power key until boot menu appears. Volume down to RECOVERY and tap power to select. HTC logo appears followed by a blank, dim screen. Wait about 30 seconds for red triangle icon to appear.

Now, hold down volume-up and tap power button. Recovery menu appears. Volume-down to "Wipe cache partition" at bottom of list and tap power key. Cache gets cleared. Then select "reboot system now" by tapping power key again. Done!

  • What is the reason I'm being downvoted when this method solved my problem?
    – rld.
    Aug 30, 2015 at 8:43
  • Well sometimes the community is real harsh to downvote without giving the reason. I hate that kind of behavior too. Discourage people despite their effort. Back to this question, I'm looking for a solution to this very problem. Although it "seems" to work for you (you observed for long enough? until now still works?), I did a dirty flash yesterday but the problem persists. The time is only 5-10 minutes off though, but it's still bugging me :).
    – Jim Raynor
    Dec 28, 2015 at 22:11
  • Issue's been gone for me ever since, actively using the tablet on various ways day-to-day. Thanks for your reply.
    – rld.
    Dec 30, 2015 at 10:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .