My Device is Motorola Moto G 1st Gen. running Android Lollipop 5.0.2

From the last 2-3 months, my phone is not installing apps. It downloads the app and even shows installing but never completes. After showing "Installing " for some time, the notification will go. If I go back to Play Store, it says "Install" and not Installing. So I have to repeat the same procedure.

I have tried clearing Data and Cache of Play Store, Download Manager, Google Play Services. I have over 5 GB space available on phone.

I have tried the above solution many times but it doesn't works. The only thing I don't want to do is factory reset.

Update: After I updated to Android 5.1, apps started to install properly so I think it was a bug related to 5.0.2

  • My first question is: The apps that are not installing- were they previously installed on this device with the same OS? Leading to the question: Can you confirm that the apps you are trying to install are compatible with Lollipop? Does this occur for all apps and, if not, which ones specifically?
    – paulmz
    Commented Sep 4, 2015 at 14:37
  • @paulmz - It doesn't matter if the app was previously installed or not, any app that is not on my phone right now will not install. This is happening for all apps present on Google Play. Commented Sep 12, 2015 at 7:43

1 Answer 1


Try following the methods below:

  1. How about you try installing the app by manually downloading it's apk which I believe, shouldn't disappoint you. You must have "Unknown sources" enabled from Security option in Settings menu in order to be able to install APKs.(Settings>Security>Check the Unknown Sources option). For example, visit http://www.whatsapp.com/android/ and click on Download apk, when download is finished you shall copy the apk file anywhere in your SD Card or internal memory which you can access, or download the apk right-away in your smartphone. You your favorite file explorer(I use ES File Explorer) and navigate to the apk file location in your smartphone and touch to open it just like you would open any file and you will get an option of installing the app.

  2. Power off your Moto G and reboot to bootloader by pressing Volume up + Volume down + Power button and you will be taken to bootloader, from there you should use volume down to scroll down to Recovery option. Use Volume up or Power button to enter Recovery mode and than wipe cache(do not execute wipe data as it will wipe the internal memory/sdcard) which can take 5-10min if on stock ROM. When done, reboot and post if you face the problem again.

  • You didn't really explain your first sentence. Perhaps inform the user HOW to manually download and install an APK. The second paragraph should be listed as a second and separate possible solution. It currently looks like the second paragraph is related to the first and may confuse users.
    – paulmz
    Commented Sep 4, 2015 at 19:44
  • 1
    The first method might work but then it is not really a solution, I can't/won't download and "manually" install lots and lots of apps. I didn't try the second method because after my device got Android 5.1 update, everything started working again. So I guess, it was a weird software problem. Commented Jun 1, 2016 at 13:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .