0

I bought a motorola moto g gen 3 a few days back and encountered a bug i can't wrap my head around.

First of: this post: Cellular data not working since 5.1 Lollipop flash adresses the same issue but since I created this account today and I lack reputation I cannot answer in that post ... I find this a rather weird designchoice for an answer based website but hey, you guys have your reasons :D hence I have to make this kind of repost :( I am sorry for that. Also for my English, its not my native language.

On the issue: I have android 5.1.1 which came standard on the phone. I set it up to my liking and for a day everything worked fine. I am from Belgium and have a data plan with mobile vikings. I think they use the Base communication lines.

But since I woke up a few days ago I can't get my cellular data to work like it should. When wifi is enabled cellular data is also enabled. But from the second i lose my wifi connection OR is shut it off I ALSO lose my cellular data connection and instantly an exclamationmark pops right up alongside the data icon. Hence it feels like they are somehow connected but set up wrong. It feels as if the purpose is to automaticaly enable cellular date when you lose wifi connection and vise versa but somehow it bugs and works the other way round.

In that other post people suggested to ask my provider about it. Changing phones might have done something on their end but so far i did not get response. The things I tried myself were shutting the phone off and on again, removing and reinserting the simcard, fizzling with options, googling like mad, factory reset and probably something I forgot. All to no avail.

My previous phone was a windowsphone nokia lumia and all worked well there. Because of problems with the battery and my drive to go android again I bought the moto g.

Please dear androiders, help me! I am losing my mind :D

0

I have a Nexus 5 with 5.1.1, and was experiencing the same thing.

It was a bit weird; I think the problem started with the 5.1.1 upgrade, but it's didn't kick in fully as a problem 100% of the time until sometime last week (1st week of September). Prior to that it was an intermittent problem, dropping about quite regularly, but returning pretty quickly.

Anyway, I rooted the phone, and reinstalled 5.1 and it's all working properly now.

0

I phoned mynprovider and we went over some options. Turns out there is nothing wrong with my phone but my APN settings were set-up erroneously. We went over those options and I set them up accordingly. Quick reboot and problem solved.

So for all you guys with the same symptoms, don't hesitate to call your providers helpdesk to run over your APN settings!

0

Running Moto G 3rd Gen at 5.1.1. Had all the same issues start the first couple days of September. Not sure what prompted the issue, but we all seemed to have it occur at the same time; is that when 5.1.1 went out?
Searched my carrier support pages for the proper settings and noticed that for "non-carrier devices" (my Moto is unlocked and not sold by them) they have slightly different APN settings. I had to change the APN field. Once I changed that, my data was back. BUT that lasted less than a day before it went back to no data again. Still missing some piece of this puzzle...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.