0

I tried to install Chrome or Google Drive on Samsung Galaxy Tab 10.1 (Android 4.0.4) but the app page in Google Play says "Your device isn't compatible with this version".

Can I install an older version? Or is there any workaround.

I updated my system.

Later update: Any other application that I tried to install was giving Error retrieving information from server. [RPC:...]

1
  • 1
    I can't figure out what the issue could be, but to install older version you can try searching the apk on the internet. There are sites like apkmirror.com that collect the apk of a lot of apps.
    – user127476
    Oct 21, 2015 at 16:49

1 Answer 1

0

What I had to do to solve this was

  1. Go to Settings > Accounts
  2. Remove the Google account
  3. Add back the Google account
  4. Go to Settings > Applications > All
  5. Clear data for applications 'Google Play Services,Google Play Store` (basically any system service or application from Google that had to do anything with Play Store)
  6. Reboot the tablet

Now I can install applications, including Drive and Chrome.

1
  • This did not work for me. I have a galaxy 10.1 P-GT7510 running Android 4.0.4
    – user193882
    Oct 26, 2016 at 23:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .