3

last night I installed SlimKat on my rooted S3 (SGH-I747M, Canada Bell) and I had no network connection, so I donwloaded the Samsung original firmware from SamMobile.com. I flashed it on and everything is working now network wise. However, when I enable the WiFi it doesn't turn on at all. Not sure what to do at this point, do I need a different firware or what? Eventually I would like to have a custom rom, but I know I need to re-root it and then install it using CWM, but I don't want to do anything until I know that I have Wifi working.

Another weird thing is that I'm currently in Prague, Czech Republic and I was able to connect to my network here (Vodafone CR) without any problem. I thought it would be locked into Bell again (This is a very good thing obviously, just don't really know why...)

Thanks in advance

  • No it was rhe firmware for Bell in Canada.... where the phone is from . @beeshyams – user434002 Dec 22 '15 at 8:27
  • @beeshyams ok... how do i find the modem only, and do i use Odin to flash it ?? – user434002 Dec 22 '15 at 8:33
  • I'm just wondering... is the modem only for the mobile data ? Because i have mobile data , its just the WiFi that isn't working . Apologies if that's a dumb question ... – user434002 Dec 22 '15 at 8:52
  • @beeshyams will do it tonight. Or tomorrow and let you know – user434002 Dec 22 '15 at 9:03
  • @beeshyams if i root it now. Install cwm and install a custom rom and i can't connect to my network (like what happened the last time i put slimkat on) is all i have to do is flash the modem and it should fix it ? – user434002 Dec 22 '15 at 12:53
1

Based on our chat, you did not do a "clean flash" ( Factory reset + wipe Dalvik cache + wipe, preferably format /system) of stock ROM using Odin.

Clean flash is always recommended if you are switching between ROMs from different sources for same Android Version or switching between versions. This is to ensure that /system does not have remanants of the earlier ROM.

What you did while switching ROM from Slimkat to stock is a "dirty flash", (see Clean flash Vs dirty flash which could have resulted in your Wifi problem.

Suggest you first clean install stock ROM and check WiFi connectivity. In case that doesn't work suggest you update modem to the latest version from complete modem list for S3 either flashing by Odin or custom recovery

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.