0

After a bootloop that I experienced after messing around with Android, I flashed a stock ROM to my LT30p using FlashTool.

Everything went smoothly, except for the fact that I can't create files in the internal memory (/storage/sdcard0) with any file explorer. This includes trying to download files from browsers, they fail instantly. So I figured it's a read-only situation going on.

I also flashed another stock ROM, clearing all data, but the problem persisted.

The funny part is that the mount command gives me this:

rootfs / rootfs rw,relatime 0 0
tmpfs /dev tmpfs rw,seclabel,nosuid,relatime,mode=755 0 0
devpts /dev/pts devpts rw,seclabel,relatime,mode=600 0 0
none /dev/cpuctl cgroup rw,relatime,cpu 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,seclabel,relatime 0 0
selinuxfs /sys/fs/selinux selinuxfs rw,relatime 0 0
debugfs /sys/kernel/debug debugfs rw,relatime 0 0
none /acct cgroup rw,relatime,cpuacct 0 0
tmpfs /mnt/secure tmpfs rw,seclabel,relatime,mode=700 0 0
tmpfs /mnt/asec tmpfs rw,seclabel,relatime,mode=755,gid=1000 0 0
tmpfs /mnt/obb tmpfs rw,seclabel,relatime,mode=755,gid=1000 0 0
/dev/block/platform/msm_sdcc.1/by-name/System /system ext4 ro,seclabel,relatime,
discard,data=ordered 0 0
/dev/block/platform/msm_sdcc.1/by-name/Userdata /data ext4 rw,seclabel,nosuid,no
dev,noatime,discard,noauto_da_alloc,data=ordered 0 0
/dev/block/platform/msm_sdcc.1/by-name/Cache /cache ext4 rw,seclabel,nosuid,node
v,noatime,discard,data=ordered 0 0
/dev/block/platform/msm_sdcc.1/by-name/SDCard /mnt/int_storage ext4 rw,seclabel,
nosuid,nodev,relatime,discard,noauto_da_alloc,data=ordered 0 0
/dev/block/platform/msm_sdcc.1/by-name/apps_log /mnt/idd ext4 rw,seclabel,nosuid
,nodev,noexec,noatime,discard,nobarrier,data=ordered 0 0
/dev/fuse /storage/sdcard0 fuse rw,nosuid,nodev,noexec,relatime,user_id=2800,gro
up_id=2800,default_permissions,allow_other,allow_utime_grp 0 0

so, from this

/dev/block/platform/msm_sdcc.1/by-name/SDCard /mnt/int_storage ext4 rw,seclabel,
    nosuid,nodev,relatime,discard,noauto_da_alloc,data=ordered 0 0

I conclude that I should be able to create files/folders as normal (since it says rw).

What am I missing? I googled this in many ways but to no avail.

Thank you for any help in advance!

PS. Phone is rooted, of course.

0

I finally fixed it. In case someone has the same problem in the future, here's what I did:

  • After googling here and there about how to completely wipe an Android phone, I read that to do that you must encrypt your data first and then do a factory reset.

So, I still don't know what caused it, I only know that now it's fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.