2

So a few days ago I build an update for my custom android car tablet with my own launcher (based on nexus 7 2013). I added a few new features and some fixes, and I added accidentally the device admin permission together with the install packages permission.

After the update was installed on the tablet, the device opened always the Android for work app when clicked something which should start an external app (like Spotify or Maps). I thought it might be something with these permission and I deleted them and reinstalled a new version of the app (not updated!), but it didn't worked, it still started the Android for work app.

Then I uninstalled the Android for work app, and now the google now app started. After uninstalling it too, the settings app keep launching?!

Has anyone an idea why this is happening and what I can do to get rid of it?

  • We can't help, since you yourself built the software. Development questions are off-topic. – Death Mask Salesman Jul 27 '16 at 12:41
  • No it is stock android and the app does nothing than launching normal intents. And these intents are normaly working in another activity, but in this specific one, android interups it and opens it own apps, because of that I think it has something to do with android it self. But if you say it shouldn't be here I can also post it on SO – Deniz Celebi Jul 27 '16 at 12:44
  • Honestly, I'm not sure if we can answer this question here. Certainly it looks strange that there's a certain app that's always run when you launch an Intent, but since this is related to your own app/update, I'm not sure we can debug it without any code or more hints (however, it's off-topic here due to development-related). You could try Stack Overflow, also try to explain the case as detailed as possible (like, what modifications you've applied) since I think it's a bit too broad as of current writing (debugging issue is off-topic on SO). – Andrew T. Jul 27 '16 at 13:08
  • Not a development question, it could be an apk installed from outside the play store and have the same behaviour, in which case it would be an appropriate question, so this is too. – ollie299792458 Jul 27 '16 at 13:21
2

Try:

  • Restarting
  • If you can (i.e. phones bootloader is unlocked): Try clearing the cache and 'davlik-cache' (By installing a custom bootloader
  • Deleting the offending app using adb (the same software you use to put the app you wrote on there)
  • Ok did everything before and did it also right now again, but it is still not working – Deniz Celebi Jul 27 '16 at 13:25
  • You deleted the app and cleared both caches? – ollie299792458 Jul 27 '16 at 13:27
  • exactly, and i removed any file that has something to do with the app – Deniz Celebi Jul 27 '16 at 13:28
  • That is very strange, because I would expect clearing both caches systemwide to deal with it, in which case I can't think of anything else but a factory reset – ollie299792458 Jul 27 '16 at 13:29
  • Are you sure you went into bootloader and cleared all caches? – ollie299792458 Jul 27 '16 at 13:29
0

Ok it came out that for some reason the package name for the packagemanager which gets the intent was empty and therefore android starts the settings app as a fallback(?). But anyways it is now solved! Thanks for anyone who helped!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.