0

I own an Alcatel VDF 300 which was factory reset but after reboot, the phone stuck at the setup screen, can't pass the Wi-Fi selection step, where it searches acount informations on the server. It sticks there even after hours of searching...

I searched in the Internet and found solutions for bypassing the FRP but none worked. - The one using an OTG USB drive didn't work because it seems like it is disabled - The one bringing the browser to connect to a site and install the Dev Settings so that I can reset the phone from the Settings (works on Samsung though) by exploiting the keyboard didn't worked neither simply because there is no way to do so.

So I'm here asking if is there a way to bypass FRP on Marshmallow,. does flashing a new rom removes the FRP?

PS: The phone is an MTK (MT6585 - I guess) and runs Android Marshmallow (6.0). I've consulted How to bypass “Verify your account” (Factory Reset Protection) already, but none of those methods work.

SOLVED!

  • If FRP was easy to bypass, it wouldn't be much good... For good or bad, manufacturers are patching every way of defeating FRP we come up with. There is no generic bypass for Marshmallow, only a few device specific exploits have been found. The fact it can't get to the WiFi selection screen is more puzzling, since FRP checks occur after that happens. – acejavelin Oct 14 '16 at 21:54
  • If you can flash the stock ROM (the whole firmware) from scratch then do it. It should flash FRP partition as well and free you from this mess. Alternatively, flashing a custom ROM without GApps (Google's Setup Wizard) would also help. – Firelord Oct 15 '16 at 9:58
  • 1
    @Firelord, it's Solved! your suggestion about the Google setup wizard lead me to fond a way to connect the phone to the computer, since it's an MTK, I connected it in META mode, this enabled ADB and I was able to hide the setup wizard package (because I couldn't remove it,root access needed). – esQmo_ Oct 15 '16 at 11:09
3

I don't know if this solution will work on a different phone model, but let me explain what I did: First I tried to get the phone being detected by the computer, so I downloaded the MTK drivers (preloader VCOM drivers) and plugged the phone in META mode with MAUI META (a tool that connects mtk to META mode and do many other interesting stuffs, repairing IMEI for example). Then downloaded ADB (the best I found is "Minimal ADB and Fastboot") With that i could connect to the phone and hidden the setup wizar. this post on reddit helped me with the commands. From the command line:

adb shell
 cd /system/priv-app/

ls (to list all installed applications) then:

pm hide <package name>

You would list all the packages with pm list packages first if you don't know the package name .

An alternative way is to use a software called Debloater

  • Thanks for sharing! Could you please edit your answer and include the package name you identified being the setup wizard? – Izzy Oct 15 '16 at 17:46
  • oh sorry, I don't remember the exact package name, but this post explains how to get a specific app and it package name and this tool lists all installed apps with their respective package names. – esQmo_ Oct 15 '16 at 18:06
  • LOL Yeah, the first one happens to be my post :) I just thought if you remember what to look for, that would make it easier for others to get an idea. OK, if you don't remember you of course cannot add that :) Thanks anyway! – Izzy Oct 15 '16 at 18:30
  • 1
    Using Debloater makes it easier to find the app and hide it just in one click thus allow bypassing the FRP – esQmo_ Oct 15 '16 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.