0

I searched for my problem but what I found either wasn't answered or was very old response and maybe things have changed since then...

I just got a Samsung Galaxy S8 and it's amazing, but maybe since yesterday notifications are a bit slow. I just answered and email that I got an hour ago from my computer while my phone still didn't show the notification. I got some test messages and again, they showed up but only after I opened up gmail app and refreshed it.

What might help find the answer - right now I'm spending most of the time on my computer when I have gmail website opened (for hangouts) and thunderbird for emails. However the days before I was mostly outside with my laptop either turned off of inactive.

Btw, I had a similar issue with the old phone (also android) but I just blamed it being 4 years old and acting up.

So what could be the possible issue? Some kind of setting on my phone? Possible network changes? (I changed cities in those days, maybe the network here sucks and phone tries to use it instead of wifi... I'm just looking for options here). Or is it just the fact that I have gmail / thunderbird opened?

Thanks in advance.

0

One reason could be you have auto-sync turned of which is resulting in emails not being synced automatically.To enable this Goto Setfings->Accounts & Sync ->tick Auto-Sync also select your google account from there and make sure "Sync Gmail" option is ticked. Another reason that may cause this can be battery savers. Try turning of "battery saving mode" on your device and test again also turn off any 3rd party battery savers if you have any or white list the Gmail app in them.

| improve this answer | |
  • I tried both solutions. Auto sync is on for everything from google except google movies. Also I'm not using any 3rd party battery saver, I only have the standard one. I checked all the settings - there's no gmail in it at all. Not as blocked, not as ignored, nothing. – lilKriT Jun 11 '17 at 20:35
  • I don't know if it's correct to write few comments in a row, sorry for that. I tried typing enter for next paragraph and it just posted. Anyway, I checked the last sync time for my gmail and it showed few mins ago. In fact I already had 3 emails waiting for more than an hour, which is incredibly annoying, and I wasn't on gmail / thunderbird on my computer then. However I keep getting notifications from youtube (many times a day) and of course I got some non important message moment ago. I'm wondering what's the point of having android phone if you can't even get gmail notifications... – lilKriT Jun 11 '17 at 20:37
  • Another update. I looked around every single option in my phone settings. Found something called "Data usage". I found Gmail and turned on "allow to use data even with transfer saving mode" on. This also should not make any difference since I was not on the data saving mode (at all) but lets hope that was it... Really strange. It's hard to hide my frustration at this point! – lilKriT Jun 11 '17 at 20:44
0

I looked around with more settings and a lot of online research and eventually I found this link:

https://support.google.com/mail/answer/1075549?co=GENIE.Platform%3DiOS&hl=en

Apparently what I really had to do was go to gmail app -> settings -> my account name below notifications there's item "inbox - sound and vibration" Turn "Notify about every message"

And that decreased the delay from hours (or never getting notifications) to 10 minutes maximum, with average time being 5 minutes.

I still don't know why this option would be off by default, seems like a very important thing. I am posting this in case someone else will have this problem.

| improve this answer | |
0

You could try to exclude Gmail app from the battery optimization setting: Go to Settings → Battery (or Power Manager) → select Battery optimization → search for Gmail and set as not optimizing battery use. This process might be different on newer versions of Android, I am using Marshmallow (Android 6).

And also in the new version of Gmail has a feature for notifying only for important messages and maybe it's turned on.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.