6

I'm roaming in Mexico with an international plan via a US-based GSM carrier. This gets me 4G on TelCel in Mexico, and it works great.

However, occasionally, for reasons unknown to me, sometimes my phone will switch off of TelCel, and switch to a cell network named "334 01", which does not provide cellular data. This happens while browsing the Internet on my phone, while tethered to my laptop, or while I'm asleep. From a quick search I gather that "334 01" is AT&T's IMSI code, but my US carrier is not AT&T, though this phone was never carrier-locked.

Is there an Android setting that I can modify to either:

  • Stop my phone from changing cell networks automatically
  • Prohibit my phone from connection to a specific cell network (in this case "334 01")

Tethering is explicitly included in my plan, so I don't think it's TelCel "kicking me off". When I notice that my data connection is gone I can switch back to TelCel by selecting it via the "Cellular Operators" menu in settings. My phone is a Motorola Moto X Pure running Android 7.0.

EDIT: Whoops, the offending network is "334 03" which is Movistar.

  • This Xposed module seems promising Add on which specific networks you want to allow roaming To test this you would need to root your device and install Xposed framework (see Xposed tag) – beeshyams Jan 16 '18 at 12:54
  • 1
    @beeshyams Thanks! It's incredibly strange, despite Android settings having an LTE preferred network the preferred network type in the debug menu was not LTE preferred. I've switched it to an LTE preferred setting, I'll leave it there for a day and let you know how that works out! – Joe Cullinan Jan 16 '18 at 14:55
  • 1
    @beeshyams That worked! If you would post your first comment as an answer I'll gladly accept it. – Joe Cullinan Jan 17 '18 at 18:41
5
+50

Problem was that the settings made in the device by manual selection wouldn't stick

Solution

Dial *#*#*4636#*#* and in Phone Info section → preferred network type choose the network type you would like to be always connected to.

enter image description here

As OP noted in their comment, the network selection made in settings was not sticking and the selection made in above menu did stick and prevent roaming (they chose LTE as preferred network)

4

There is a setting to "fix" your device to a given network:

Settings › More … › Mobile networks › Network operators:

Settings

By default, this is set to "automatic". But there's an option to "manually select". This will then scan for available networks, and let you chose one (obviously only possible with the desired network in reach). Having done that, whenever the chosen network is not available, you'd simply have "no network" – it wouldn't switch to any other operator, however strong his signal might be.

I've often used that in the past before going abroad if I wished a device to not "accidentally roaming" even for calls. That way my then provider couldn't fool me with costs for "twice redirected calls" (from home to roaming to mailbox-at-home-network): Manually selecting my home network before departing, the device found no suitable network in the target country :)

  • This is what I've been doing to switch back to TelCel. It seems that even a momentary disruption to the TelCel signal will kick me onto the other network. I can switch back using this method but it will only solve the problem until the TelCel signal gets lost again. The problem seems to be that to my phone both networks seem to be suitable, but the non-TelCel network doesn't provide any connectivity. – Joe Cullinan Jan 12 '18 at 21:24
  • 1
    That's still not working as designed then, or something has changed. Manually selecting a network is meant to stick; if you wanted to make sure to be "connected anywhere" you'd use the "automatic" option. The only reason I could see it still happens (except from changes on the Android end) is both networks sharing the same MCC and MNC, which would basically mean they are the same. TelCell in Mexico has 334-020 – 334 001 would be "Comunicaciones Digitales Del Norte, S.A. de C.V.", see Wikipedia. – Izzy Jan 12 '18 at 22:10
  • 1
    It's definitely broken then. For what it's worth I had the same issue when I was using Marshmallow down here last year, with the phone hopping off of TELCEL and onto Movistar. At least it makes sense knowing that the offending network 334 03 (not 01 as I mistakenly stated before) is actually Movistar just failing to send the network name since TMobile will allow me to roam with either. It's just frustrating that it refuses to stay on TELCEL. Luckily changing the debug menu setting for preferred network type seems to forbid connecting to Movistar. – Joe Cullinan Jan 17 '18 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.