Question Summary

How do I stop Samsung Internet from popping up when I select text in Gmail and click on the 'Web Search' "button", and instead bring up something else, such as DuckDuckGo search, or Google search, but not Samsung Internet?

I do not want to root this device in order to fix this issue, because if I had to go to that level, then I would just cope with it by copying the text to tge clipboard, followed by pasting into a web search engine outside of the Gmail app.

Android version

android details

Device Model

device details

Detailed Problem Description

Recently, perhaps due to some Android update on my Samsung Galaxy tab S3, the behavior of the 'Web Search' popup dialog (see first image below) has changed. Before, it would allow me to search in some browser or other app, but now it pops up something called 'Samsung Internet':

Gmail screenshot with web search pop up

This is a screenshot of what pops up when I click on 'Web Search':

Crappy Samsung Internet

Things that I tried

I have tried selecting text in other apps, and I see something different, and that difference is acceptable to me, as it is searching in DuckDuckGo search engine (this other app happens to be Firefox):

Selecting text from Firefox

I looked inside the Gmail settings, and there does not seem to be anything there that indicates how to change the default search engine that it uses.

I looked at Settings/Apps/Gmail that was referenced by https://www.greenbot.com/article/2879150/how-to-change-the-default-search-engine-in-android.html but I did not see any indication of which search engine Gmail itself would use. My theory was that Firefox has some specific setting that can be changed, so I figured that Gmail itself would as well but that is not the case.


'Settings, choose Advanced, then Set Search Engine' does not show anything about search engines at all.

  • I have the same issue. "Search" opens Edge and "Search in Edge" opens Edge again. Commented Aug 3, 2020 at 9:00

1 Answer 1


For Android 12 (and maybe your phone):

Settings -> Apps -> Samsung Internet (or whatever app you are trying to avoid) -> set as default -> clear defaults.

This worked for me when Google took over "web search" events in gmail.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .