0

I have been using my Huawei Honor 8 for about 2 years now. I live in the US. And I have been using Google Play Store and other apps without any issues. Last night my phone ran out of charge and died. When I plugged it in and turned it on, I received tens of notifications stating: "Get Google Play Services. [App name] won't run without Google Play Services which are missing from your device". I Double checked it, and Google Play Services are still installed. However, whenever I attempt opening any Google-related app, I get an error message saying: "Core GMS packages. Install core GMS packages to use [App name]".

Has anyone encountered this problem before? What could cause it? And how could it be resolved?

Model Number: FRD-L04 Build Number: FRD-L04C567B398 EMUI version: 5.0.4 Android Version: 7.0

  • 1
    The internal data of one or more Google related apps may be corrupted when the phone ran out of battery. Try to clear the cache and user data of the core google apps/services. – Robert Nov 16 '18 at 19:13
  • Thank you, unfortunately this did not work. I tried clearing data and cash for all apps I had problems with and saw no success. I will keep trying – Surok Nov 16 '18 at 20:56
  • You can also try to deinstall and then re-install the updates of Google service apps, e.g. this one play.google.com/store/apps/details?id=com.google.android.gms – Robert Nov 17 '18 at 10:41
  • Thanks again for your advices. I backed up my phone and hard rebooted it. This solved the problem! – Surok Nov 19 '18 at 13:11
  • @Surok You may like to self answer. See How do I write a good answer . This could get you some thanks by way of reputation and help you contribute better to the site :) – beeshyams Nov 28 '18 at 14:52
0

The issue was resolved. Since only certain Google-related apps were affected, I was able to back up everything else I had on the phone, including data and apps. After that I ran the Factory Data Reset and used my back up to make the process of setting up the phone and all the apps, I had been using, easier. The problem was resolved immediately after the reboot and I was able to set up the phone with my Google account.

/Posting this answer to end the thread/

P.S.: Prior to running a factory reset, I attempted clearing cache and data for the affected and related apps and resetting phone settings without deleting all data. That did not work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.