2

Is it in any way possible to replace CM7's boring messaging interface with the stock messaging app from the LG stock roms (the one with chat bubbles), also, where would I be able to get a keyboard similar/exactly the same to the stock LG keyboard on the Optimus Net?

This is what the stock keyboard looks like (I couldn't find a picture in portrait mode, sorry): Stock Keyboard Image.

I found a ported stock LG keyboard, but as you can see in Cyano, there is a useless smilie button and every single button is bigger than what they're supposed to be from the LG keyboard.

Could someone help me/direct me to how I might be able to replace the messaging app and keyboard from CM7 with the apps I'm looking for? Thanks!

1 Answer 1

2

Download the apk files of the stock keyboard and messaging apps and copy them to the current directory. You can also copy them from /system/app/ directory in the system.img file(use magiciso to mount it) present in the stock firmware file(usually .tar) Start an adb session and execute the following lines:

Mounting system partition as read-write:

$ adb shell mount -o rw,remount -t yaffs2 /dev/block/mtdblock03 /system

Removing CM's apps(change the names):

$ adb shell rm /system/app/CM_messaging_app.apk
$ adb shell rm /system/app/CM_keyboard_app.apk

Installing stock apps(change the names):

$ adb install stock_messaging_app.apk
$ adb install stock_keyboard_app.apk

I would recommend 'hacker's keyboard'( https://play.google.com/store/apps/details?id=org.pocketworkstation.pckeyboard&hl=en) over the stock keyboard apps though.

3
  • I've tried your method with installing multiple versions of the stock Gingerbread Mms.apk, though for the Mms apps I found, it always fails to install. What could be causing this?
    – user14479
    Apr 24, 2012 at 0:00
  • what error message are you getting?
    – Ruben Roy
    Apr 24, 2012 at 12:53
  • When I try to install the apk manually (for testing purposes if it would work before mounting to the system) I get application not installed messages. I then tried mounting it to the system/app/ folder via the terminal then my messaging app just vanished altogether.
    – user14479
    Apr 24, 2012 at 14:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .