My Galaxy Nexus detects wifi signal(at home) but can't connect to it.

I cant connect to wifi. The wifi icon doesnt appear beside the time on the upper right of the screen. When I try to access facebook it says connection lost. But wifi works properly well on the laptop.

I've switched the ON/OFF , restarted the galaxy Nexus and still nothing.

Please help.

  • 1
    In Setting => WLAN, what do you see when you tap on the WLAN you want to connect to? Signal, security, advanced options?
    – ott--
    Jul 3, 2012 at 7:40
  • I have the exact same problem. I followed tried all of the things you mentioned, but the result is the same. This just started happening. Occasionally, I get an intermittent connect, but most of the time I get that immeidate "Failure to connect to network" message. I have tried a couple different Wi-Fi apps, too.
    – user21198
    Oct 9, 2012 at 9:07

2 Answers 2


A few things to try:

  • Ensure that the Wi-Fi network you are connecting to is an infrastructure mode (router) and not ad-hoc (shared connection via another phone or laptop) as Android doesn't support ad-hoc mode out of the box.
  • Disable the Avoid poor connections option under Settings -> Wi-Fi -> Menu -> Advanced.
  • On the same screen, switch the W-Fi frequency band from default "Auto" option to the one your router uses (2.4 GHz Vs. 5 GHz).
  • Check your router settings to ensure it's not filtering by MAC address. If it is - either disable that option, or add your phone's MAC address to the list of allowed devices.
  • Check the settings on the Wifi network on the Settings -> Wi-Fi screen. Long-press on the network you are trying to connect to, select Modify network, and check that the settings for Security are correct.
  • Try re-connecting fresh. On the Settings -> Wi-Fi screen long-press the network you are trying to connect to and select Forget network option. Try re-connecting to it.

I had the same problem and then remembered that the new router was set to only accept connections by MAC address. When I added my Nexus one MAC address to the new router, it connected perfectly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .