0

My Samsung Galaxy A10 SM-A105FN (running Android 11) is stuck on the lock screen, and whenever I enter the correct pattern, the screen goes black for a few seconds before coming back to the lock screen

The phone has TWRP 3.7.0, is rooted with Magisk 26.1 and uses EdXPosed, but neither of these have any mod/module installed. EdXposed is disabled. Also, when I press the lock button on the side, to turn the screen off then on, the background changed, despite no setting having changed that.

What I tried :

  • Soft reboot/reset
  • Hard reboot/reset
  • Clearing Dalvik/ART folder
  • Clearing Cache Partition
  • Reinstalling Magisk
  • Unfreezing all apps

Is there any way to fix it please ?

EDIT : I decided to reset my phone as I couldn't do anything else at the time.

However, an interesting solution has been suggested after my reset, but I have no idea whether it could've worked or not.

2
  • 1
    Even before first unlock after reboot the phone should connect to your local Wifi, does this happen on your phone? If it does not this may indicate a fatal error of the user data file-system and/or the file-based encryption system.
    – Robert
    Jul 12, 2023 at 11:21
  • The phone is in airplane mode after each restart, unfortunately Jul 12, 2023 at 11:27

1 Answer 1

1

From TWRP's File Manager go to /data/system and delete

  • gatekeeper.password.key
  • gatekeeper.pattern.key
  • locksettings.db
  • locksettings.db-shm
  • locksettings.db-wa

If any of these is missing, let it be.

Reboot. Lock Screen should be removed now. Set a new one and check if the problem persists.

3
  • Thanks ! I, since then decided to reset my phone despite all the things stored on it, and thus cannot try your method. Robert, above, said it could be caused by corruption of the "data" file-system, and I think it is highly possible in my case. Sorry for the useless post as of now ! Aug 5, 2023 at 2:44
  • @ChuckLennon I believe this sometimes happen when a backup is restored from twrp. There may be other scenarios where this could occur. Basically the problem occurs when the old password format was different than the current one. Eg. old one was a pattern lock but the phone starts to ask for a pin to unlock, or the old one was a 6 digit pin but the phone asks for a 4 digit pin, so on and so forth. Deleting the screen lock files removes the password.
    – 44yu5h
    Aug 5, 2023 at 7:13
  • Thanks but it cannot be, as I did not restore a backup. So I think it was due to some data corruption. Maybe I froze/disabled apps that shouldn't have been Sep 12, 2023 at 13:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .