1

I'm using a rooted Revvl 6 5G - TMAF025G_0.05.29 - MT6833 - Android 12. Without a recovery.img, I rooted using Magisk_Patched-boot_a.img. After this, I used the RO2RW module to aid in making the partitions R/W mountable with:

adb shell
su
mount -o remount,rw /system

The goal is to install apps as system apps using:

adb push xplore.apk /system/apps

How do I go from mounting the /system partition as R/W to 'adb push' without losing the permissions? How do I push xplore.apk to /system/apps while the partition is still mounted R/W? If I exit the root command and then exit the Android shell, the partition resets to normal. So I'm trying to figure out how to transition.

0

1 Answer 1

2

adb push is never affected from calling su from within a shell. If you execute su within a shell a new shell instance is created that get the root permissions.

However adb push does not use a shell at all. Instead the push operation is directly executed by the adbd on the Android device.

The only way to get root permissions in adb push is by calling adb root. If the adbd running on the device supports it, adbd will restart itself and keep the root permissions.

If you now execute adb push all operations will be executed with root permissions.

3
  • So the response I am getting from pushing: C:\Platform-Tools>adb push Magisk.v26.3.apk /system/apps adb: error: failed to copy 'Magisk.v26.3.apk' to '/system/apps': remote couldn't create file: Permission denied Magisk.v26.3.apk: 0 files pushed. 55.0 MB/s (982920 bytes in 0.017s) comes after I use adb root and after adb shell, su, mount -o remount,rw /system, and exit twice to back out to adb push.. How can I achieve the proper permissions to push to the root directory?
    – NinjaAdmin
    Sep 13, 2023 at 3:22
  • I tried running su, mount -o remount,rw /system from the smartphone shell and then tried adb push from the PC and got the response: C:\Platform-Tools>adb push Magisk.v26.3.apk /system/apps adb F 09-12 22:25:50 11244 2512 file_sync_client.cpp:326] protocol fault: failed to read stat response: No error
    – NinjaAdmin
    Sep 13, 2023 at 3:26
  • @NinjaAdmin If you can not directly adb push you first have to push the file to a place where you can write (e.g. /sdcard), then open an adb shell, execute su and finally copy the file from /sdcard/ to /system/apps.
    – Robert
    Sep 13, 2023 at 6:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .