I found several questions here where people want to merge several of their contacts into one.
I'm having exactly the opposite problem:

On both my Android devices (Google Nexus 4 and Nexus 7), two of my contacts were automatically merged, without noticing or asking me first.

I noticed this when I didn't find my mother anymore in my contacts. After some searching, I found that my father's entry now had two cell phone numbers (his own and my mother's) and two dates of birth (again, his own and my mother's).

Now I understand how it's possible that they were recognized as "similar" (both share the same last name, street adress, non-cell phone number and e-mail adress), but it's beyond me why on earth it would just merge them automatically, without any notice?

Please note that they are still two separate contacts in the GMail web interface.
They are just merged in the contact apps of both my Android devices.

I had another Android phone until a few days ago (HTC Wildfire with Android 2.2), but I don't know if they were already merged there too or if this is a new bug in Android 4.2.

Finally, I compared my complete contact list on my phone with the one in GMail, on order to find out if more contacts were merged.
But my parents were the only ones, even though I have a few more married couples with the same names and adresses in there.

Any idea why this happens and how I can separate them into two different contacts again?

  • 1
    Same here: my Google Nexus 4 merged at least my mother and brother into one account (it got merged under my brother). The bad thing is: I don't know which other contacts it also merged. Apr 5, 2013 at 10:15
  • Does this still happen to you? My contacts mix up erratically each time I readd my carddav account. This is so annoying :'(
    – bot47
    Jun 29, 2015 at 18:47
  • No, it happened just once, when I asked this question. Then I separated the accounts like described in my answer below and since then, it never happened again. I still have the same phone and the same tablet, though. Jun 29, 2015 at 19:23

8 Answers 8


I found a solution that kind of works, but IMO it's still unsatisfying.
After some googling, I found that this is a known bug in Android.

Apparently it's fixed (the issue is closed), but I don't think so, because not only do I have these problems now, there are also comments with complaints which were posted after the date when the issue was closed.

One of the comments had a solution that works for me, but it's not ideal:

When I edit the contact (which has my father's name, as mentioned in the question) it shows both contacts to edit...still on the same screen, but clearly separated as different contacts.

On this screen, I can separate or merge them in the options menu. When I choose to separate them, they become two different contacts again...but only on this device. I have to repeat that on the other device in order to separate them there as well.


If you want to keep your Whatsapp and Gmail contacts separated. Go to settings accounts take off auto sync. Make sure Google or Whatsapp is NOT running in the background (very important)Delete Google and Whatsapp account from settings/accounts, there only (Only on settings/accounts). Open google/gmail and login/Sign up. It will ask you to put on auto sync, let it auto sync and load you email and contacts. Close all running background again. Go to setting/accounts, take off auto sync. Now open Whatsapp, it should only have your phone contacts only (whatever your set to show as phone contacts)

Hope it works for you, running Android 6.0


I have tried the Separate Contacts option on my ZTE Valet Android 4.1 phone. If I perform it for one contact, it applies to ALL merged contacts. I like this, but it does not seem intuitive. To separate merged contacts in Android: Open Contacts. Select a contact that is merged. Do NOT edit the contact, instead at this point click the menu option (lower right). Then click Separate Contact. As I said, for me this separated ALL merged contacts, not just the selected contact.


I solved it by disabling the WhatsApp contact sync.

Go to Accounts > WhatsApp > Sync > Disable

Maybe WhatsApp and Google are conflicting with each other when both sync.


First make sure that all contact are back up with gmail then close mail sync. Then Go to settings >permission >permission >contact >contact and dialer first deny permission And allow permission again And then on your Gmail sync you will get all your contacts properly.


I found a 'near' solution for my Moto-X (2014) running OS 5.1.

  1. Go to Accounts, and turn off Auto-Sync Data
  2. Go to Apps, find Contacts Storage and Clear Data
  3. Go to Accounts, Google (all of the sync toggle should be off at this moment)
  4. Sync only the Contacts by touching the Sync toggle button, and wait patiently until the sync arrow symbol stop (meaning sync is complete). It took me about 15 minutes for me as I have 1000 contacts with many pictures on each contact.
  5. Go back to Accounts, and click Auto-Sync Data

With this, I still see few accounts that are merged, but it is way cleaner. If you have photos on contacts, some photos will also be screwed up, but at least it solved the auto merge issues 90%.

Hope it helps.


The best solution for all android phones is to:

  1. Goto Contacts app
  2. Click on the three dots near the search button.
  3. A list menu will display , click onto Manage accounts.
  4. Delete the other accounts showing here like Whatsapp (It will delete only contacts of Whatsapp, not data of Whatsapp, just relaxed), Duo etc, expect Google.
  5. After deleting the other accounts, restart your phone.
  6. Now your contacts is showing ok. Waw...
  • I do not use WhatsApp and my Telegram account is not displayed in the Contacts. I still have the issue of contacts spontaneously merging, though. Samsung A50.
    – dotancohen
    May 4, 2021 at 16:20

I solved this issue in my Realme 2 Pro phone this way:

  • Open Accounts & Sync
  • Goto Gmail and open it. Removed all the other accounts except my Gmail account.

Automatically it solved the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .