I had this before, formatted it and now it's happened again.

I suspect it's the problem mentioned here but I don't understand how to apply the fix from that thread.

I thought I had to download the file, rename it to update.zip, stick it on the phone's internal SD card, go into recovery mode and run "apply sdcard:update.zip" but I get an error when I do that which says:

E:signature verification failed / Installation aborted.

I'm not even sure if the fix is the right fix or the process is correct either, but if they are how do I get around this signature error?

It's a Galaxy S, running Froyo.

  • That fix is only for the Vibrant US variant model of the Galaxy, with this specific problem the internals may be different enough that applying their patch won't work, or could even cause you more problems.
    – GAThrawn
    Dec 22 '10 at 23:11
  • Have you tried another Micro SD card in your phone. It would rule out there being a fault with the phone.
    – Conn Darcy
    Jul 4 '12 at 20:29
  • I just put my dads SD card into my phone and it says damaged as well. but when it is put back into his phone it works fine. looks like an issue with my phone :/ Jul 4 '12 at 20:42
  • it must have to be something with the connector then. Can you read it on the PC after you 'formatted' it on the phone? (Just see if you can at least still write to it via the phone). Has the connector some visible problems from forcibly inserting/removing?
    – ce4
    Jul 4 '12 at 21:52
  • Please also check Micro SD card physically damaged?. Some of the answers there are comparable to advices given here, and some more might prove helpful. If so, please let us know.
    – Izzy
    Aug 19 '12 at 23:40

Have you tried removing your SD card, putting it in a SD card reader and plugging into a PC? Windows will auto-detect and repair a lot of file system errors if you let it. See also this previous question.


Faced a similar problem with Motorola QUENCH. May be caused due to overcharging of batteries.

Solution a) Remove microsd card and connect it to a PC using cardreader and copy data on to computer.

b) Mine failed the first time midway during copying.

c) So took a small sandwich snap bag (new and totally dry) wrapped my microsd card in a couple of paper towel or tissues (dry ones, put this tissue wrapped micro SD card in the snap bag and click locked it and put it in the freezer.

d) Took it out after 8 hours.

e) Was able to copy the full contents into PC.

f) Need to try it in the phone tomorrow, or else go for a new SD card


This sounds like the partition entry in the Master Boot Record (MBR) of the SDCard is damaged.

The best thing to do is, to do a low-level destructive format of the said SDCard in question, by using a partition manager such as GParted or Acronis, delete the entire partition on the SDCard, and recreate it again. Once the partition is created then perform a format on it.

Its difficult to pin down where the source of the issue is, the Camera uses FAT32 filesystem, Android uses FAT16 so that could be part of it despite being "compatible" in the sense of the word.

For future reference, go into Settings > Storage > Unmount SD Card, this will take a few seconds, the Android OS will safely eject the card for removal.

Alas, by force removal (intentionally or unintentionally) without unmounting can be catastrophic, because behind the scenes, the Android OS is caching the filesystem's buffers in RAM so it gets out of sync physically.

This explains why, if not, in all desktops, such as Windows, Linux, Mac, you have to safely eject it in order for the filesystem's buffers to be flushed to the disk. This applies also to all kinds of medium, be it hard disks, flash, and yes, it did held true back in the days of 5.25" floppies.


Looks like you have the same problem as from this question. I recommend using ROM Manager to flash the update.zip instead of the device recovery. You need root!

  1. Put the update.zip in your downloads folder (/sdcard/downloads)
  2. Install ROM Manager
  3. Open it and choose "Flash ClockworkMod Recovery"
  4. It should prompt for your device, select it
  5. Choose "Reboot into Recovery"
  6. It should reboot the device, select "reinstall packages"
  7. This should boot into Clockwork, you may have to do step 6 twice to get there
  8. Choose "install zip from sdcard"
  9. Find and select /sdcard/downloads/update.zip
  10. Let Clockwork do the update!
  • Following Step 5, I don't have an option to reinstall packages.
    – bcmcfc
    Dec 27 '10 at 13:36
  • Interesting ... perhaps you have the newer version of device recovery, I don't believe it works with Clockwork yet. You could try the following: 5) Choose "Install ROM from SD card" (or similar) in ROM Manager and select /sdcard/downloads/update.zip 6) Let Clockwork do the update. Dec 27 '10 at 19:21

If everthing else fails, I would try to do a factory reset of the phone - you might be in luck and it's just a software glitch that appeared when you removed the SD card the first time, rather than a hardware problem. Otherwise, you will have to send the phone back to Sprint for repair :-(!


Did you try turning your phone off then back on again?

My Mom's SD card kept saying "damaged card, reformat", but then when I hit reformat it didn't work. So I turned off the phone and then back on and it is now working just fine.

She had a 8GB micro SD card and her phone is the LG Marquee.


The problem with the Signature Verification Failed error is as a result of attempting to flash an unsigned .zip file with the stock recovery. Installable .zip files such as the one in that thread normally require a custom recovery, one that doesn't check to verify that the .zip file is signed with the phone manufacturer's unique key.

The problem with the SD card may just be exactly what it's telling you, it needs to be formatted. Try popping it out of the phone and into a computer using an adapter, see if you can back up the SD Card's contents to a temp location on your computer, put it back in your phone, let Android format it (which will erase all data in the process) and test it out, make sure you don't get any more errors. Once that's been verified, you should be able to copy your data back onto the SD card.

If it CONTINUES to happen, you may have the beginnings of an actual hardware failure on the SD card, and you might want to look into getting it replaced, or at least swapping with a known-good card for a while to see how it works.

Good luck!


Not the answer you're looking for? Browse other questions tagged or ask your own question.