A week or two ago my battery life indicator for my Motorolla Atrix 4G has ceased to working properly. The indicator indicates the battery drains ridiculous fast and it's inaccurate. I'll fully charge it and after unplugging it for an hour or so, the indicator is down to 1%. It remains at 1%, though, for up to a day.

Taking steps to avoid draining my battery is a separate discussion that doesn't have to do with this topic. I specifically need to know what I should do about an inaccurate battery life indicator. Is there a way to reset the indicator? Should I contact Motorolla or is this a software issue?

Thanks in advance!

Edit: The first thing I tried was replacing the battery with a new one. This did nothing to resolve the problem.

  • Maybe the battery is knackered, a replacement battery is needed?
    – t0mm13b
    Feb 20, 2013 at 15:24
  • Well, that exactly sounds like the reason given for battery calibration -- controversial as that topic might be... I know the following should not be done too frequently, but have you tried to let the battery drain once until the device switches off, and then (in one run!) re-charge it to 100% without disconnecting the charging cable?
    – Izzy
    Feb 20, 2013 at 16:14
  • Not sure how I failed to include this, but replacing the battery with a new one was the first thing I tried. No difference. And I'm sure I've tried that, Izzy. I usually fully charge my battery. Another phenomenon that started before this inaccurately fast draining indicator issue was that when I would "fully" charge the battery, the indicator would never read 100%. It would always be 90-something.
    – mellis481
    Feb 20, 2013 at 16:25
  • To decide whether it is a soft- or hardware issue, you might try a factory reset (this will also be the first thing Motorola service will ask you to do). Keep in mind, however, that this will wipe away all your data and all the apps you've installed, so make a good backup first.
    – Izzy
    Feb 20, 2013 at 16:43
  • I'll try a factory reset and update this thread after I do. Thanks for your continued input.
    – mellis481
    Feb 20, 2013 at 18:01

2 Answers 2


Did you install some program right before it happened?
Did you open a program, made changes, saved, and this happened?
Are you using a custom kernel or ROM?

If it's a new program, try to uninstall it first and check the results. If you didn't install anything BUT used a program before the battery meter broke, then try clearing the data and cache of that program to set it to defaults.

If the above did not work then you might need to report the kernel to it's respective developer or try to flash another kernel/ROM (if using a custom kernel/ROM), and if not. A factory reset might fix your problem like what Izzy said. I recommend using Titanium Backup to backup your files because its easy to restore afterwards.

If it still did not help and you get a fast battery drain, then it is most likely a hardware problem, eg. power IC might be shorted


To reset the battery stats you just need to go to Recovery and Wipe battery stats. Its best if you do this with your battery fully charged. Its wise to leave the phone an extra 10-20 minutes when wiping stats to ensure the battery is fully charged.

  • 1
    That is a myth! It has been debunked by a Google developer, see this
    – t0mm13b
    Feb 20, 2013 at 16:00
  • As t0mm13b said (+1; developer mentioned is Dianne Hackborne). battstats.bin only holds data about how much battery which app has been "eating". Still, calibration of the battery itself is a different issue...
    – Izzy
    Feb 20, 2013 at 16:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .