I am currently abroad. I have internet on my PC via a RJ45 cable on Win7 PC. It works fine through a proxy (address + specific port).

Now I want to use my smartphone but there is no wireless connection in my room ...

So how to create a hotspot from my PC (which has a wireless card) so I can go online with my smartphone (which also has the wifi function)?

I tried the virtual router solution manager and Connectify and the classical solution proposed sites (control-> Network and Internet-> Network and Sharing-> new connection-> ad hoc wireless network -> name + password + WPA2) then share the map. But without success ... I mean the Android phone says I am connected but I can't reach anywebsite with chrome or the preinstalled Android Internet browser. Usually I succeed with this virtual router goal time is not working probably the raison de proxy application!

PS: If it's easier I'm also starting to connect my pc to the internet via usb cable. But rooter my smartphone as my smartphone procedure is complex ...

  • I wonder that it even says it's connected! Is your device rooted? To my knowledge, Android does not support ad-hoc mode out-of-the-box. Usually one sees ad-hoc "spots", but cannot connect to them. If you can install apps (e.g. via mobile network or another hotspot), you could use e.g. Fing - Network Tools to check whether you can reach the router or beyond per ping etc.
    – Izzy
    Apr 10, 2013 at 6:18
  • Hum my mobilephone is not rooted (is a ZTE blade III). Thanks I ll try with fing network tools
    – S12000
    Apr 10, 2013 at 9:19

3 Answers 3


Based on my experience, when using a virtual router on a PC with an internet connection only through proxy, in order for your Android device to connect to the same proxy your pc is using, you have to configure your WiFi connection proxy settings on your Android device to use the same proxy settings on your PC. Afterwards, you can succesfully connect using your android phone. I've already tried it on my Note3.


did you specify the proxy configuration when you were setting up the network, you need to enter the proxy details in the network configuration try Google nexus 4 android network configuration website its for nexus 4, but hope its similar to any other android device.

http://support.google.com/android/bin/answer.py?answer=1649770. get an english one or translate this page if its in french.

Hope it helps

  • 2
    "translate this page if its in french" Or just remove the language hint (e.g., "hl=fr") from the URL.
    – ale
    Jun 9, 2013 at 11:33

An answered by @p057 you need to set proxy in Wi-Fi settings on your phone. The reason is that hotspot network (AP or ad-hoc) cannot be configured to use proxy. Proxy is used on per-connection basis by apps themselves. It's not enforced system-wide. For details see Why proxy set on Android does not work when used as hotspot?

  • HI Irfan, this is actually such an old post that I do not have this problem anymore. I will accept the answer of p057. It may help people having currently the same issue.
    – S12000
    Oct 24, 2019 at 16:45
  • @S12000 that's good. Answer is for future visitors' reference, it's applicable to all Android releases available to date. Oct 24, 2019 at 16:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .