I have a stock Captivate on AT&T. I've tried to watch videos at least a dozen times, and maybe twice it's worked as I would like it to.

Problems include:

  • "This video cannot be played". I saw the question about "allow mobile playback" flag, but I get it on user-created stuff too (not just commercial stuff). Is there a way to check if the flag is set, say from the desktop web interface?
  • 20+ second load time before playback starts, even for short videos, if it works at all
  • Sometimes I wait over a minute and the "spinner" ("Loading video") never goes away
  • Once it starts playback, if the buffer runs out, I can't get it to start again. The buffer indicator might start growing again (pale red line appears again and gets bigger) but nothing I do can make it start actually playing. I hit play/pause, scan forward/backward, tap the time bar, etc; nothing happens.

Some notes:

  • I have tried HQ and not-HQ; both have issues though HQ is worse (not surprising)
  • I have tried it on WiFi and 3G; 3G actually seems a little better
  • I can watch YouTube just fine on my laptop, etc, over the same wifi connection
  • I have used the wifi analyzer app (forgot the name) to inspect spectrum; there are no conflicting / overlapping networks in my area
  • I can download podcasts on Listen at ~10+ MB/min (estimated by my watch) so it's not something wonky with my wifi connection
  • I've rooted the phone but only so I could fix a corrupt wifi settings file (known issue, but I'm having trouble finding a ref link right now). I'm pretty sure the issue is not related, and I'm not running any other superuser stuff.

I'm at a loss. I have no idea how to track this down -- there's no particular error to look up, just general crappiness. Is it just me? Does everybody have this terrible of an experience? Would the "lag fix" do anything for me? Is there a better 3rd-party player? (someone mentioned sideloading VLC)

I don't view a lot of YouTube videos generally, but when I do get a chance to look at them it'd be nice to be able to do so on my "super" phone...

  • 2
    What version of the YouTube app are you running? Is your OS 2.1 or 2.2? And no, a lag fix should not affect this. I have most of these problems, though very infrequently, and it's been the same whether I've had various lagfixes or not. Commented Jan 4, 2011 at 5:52
  • 2
    Could you rephrase "Why does my YouTube app suck" to me more like a question that would contain answers that could solve your problem? The body of the question has some good points. Commented Jan 6, 2011 at 16:25
  • Voted to close, with no further info it sounds like a "why doesn't this work as well as i want it to". Commented Feb 13, 2011 at 18:30

2 Answers 2


Maybe it's not the whole answer but two things seem to have made a big difference:

One, my Captivate was recently upgraded to Froyo officially. The new Youtube app seems to perform remarkably better.

Two, and this is the really interesting bit, I switched from WPA on 802.11g to WPA2 on 802.11n, and my wifi speeds went from ~200-300k to 4-5M. Not sure exactly why but it's definitely something to consider if you see performance problems in an app that relies on the network...


Some videos just can't be played on your phone because the bitrate (or needed processing power) is too high for your device. This might even happen in the middle of a perfectly working video, because it's using a variable bitrate (which just rose above what's possible). That's why Youtube can get slow as well for a short time. It only gives up when the processor is at near 100% and it starts missing a lot of frames. That's actually good design. Apart from that, I think there might be some bugs in YouTube yet (but alas it is not an open sourced app).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .