Update: Recent versions of Play Music seem to have this issue fixed.

Recently installed a new ROM on my Galaxy Nexus and am trying to redownload all my music from Play Music (I do have All Access, so I can't just transfer files). I need to keep them offline because I have no mobile data connection, only wifi.

When I try pressing Keep on Device in the options menu of the playlist, it gives me a toast saying "This music is only stored on this device". Also strange, where there should be an image of the pin, it is just blank. You can still press the area and it'll give you the same message. The Last Added playlist is the only thing I can't keep offline for whatever reason. I tried installing older versions of the app, but no dice (up to v5.0, since that's when all the All Access stuff was added, i think). What can I do to fix this?

When trying to keep on device:

Screenshot Screenshot

Invisible button where pin should be:

Screenshot Screenshot

EDIT: I tried decompiling the apk and that toast string named "toast_cant_pin_side_loaded". And the function in which it is called seems to imply that the playlist is either unpinnable or had some problem while pinning.

EDIT 2: Just noticed that in the playlist, the latest song added was some song that wasn't part of my library (The Phantom pt. 2 by Justice). I pressed add to library, but that didn't fix the problem. I pressed remove from library and it didn't fix anything, but it's no longer in the playlist. It doesn't seem to be on my device and there should be no reason why it would be on my device. Also, I tried manually creating a playlist with all my music and that pins just fine. That is not a solution, as I want to have Play Music automatically download new songs without me having to manually add them to the playlist.

EDIT 3: Flashed the new stock 4.3 from Google (after wiping of course), and the same problem >:(. So it seems this is a problem with the app itself, and not my ROM.

EDIT 4: Same problem exists on another Galaxy Nexus and a Nexus 4 I tried.

4 Answers 4


Found a solution, follow the link and download version "4.4.811H.526848".

Install the old version and pin the last added playlist, then use the play store to update to the latest version.

Your last added playlist will now be pinned, when you update there is no still no pin icon but it is pinned.

  • Tom... I think I love you. Commented Sep 1, 2013 at 16:02

If I understand correctly, the message means that you can't set the tracks to be kept on the device, since they are currently on your device, not from Play Music. Even the toast string toast_cant_pin_side_loaded suggests this (see Sideloading). Unfortunately I can't confirm this since Play Music isn't yet available in my region.

  • I'm not entirely sure what sideloading means in the context of Play Music. Typically it means to install a package via USB from your PC, right? Commented Jul 30, 2013 at 9:47
  • In this case it means that you have the MP3 files on your device, either in internal storage or your SD card, and that they've been loaded there from somewhere else than Play Music. Commented Jul 30, 2013 at 9:48
  • The MP3 files are located at /data/data/com.google.android.music/files/music. Clearing the data from the app manager seems to clear everything in /data/data/com.google.android.music/, so there is not already an MP3 file there. Commented Jul 30, 2013 at 10:07
  • You don't have any music in your Internal or External Storage that you didn't download from Play Music ? (Edit: missed the reply button...) Commented Jul 30, 2013 at 10:18
  • No, I wiped everything so it should be clear. My Galaxy Nexus only has 16GB internal storage, no external storage. It is reporting about more than 12GB remaining, and before I had more than 6GB of music so it's definitely gone. imgur.com/ZtZu95l Commented Jul 30, 2013 at 10:18

I think you should try do a full wipe data/factory reset using your preferred custom recovery ..and then re-flash the ROM and tell us what happens.

  • Just tried full wipe and re-flash to the latest stable CM 10.1, same problem. I'll try stock 4.3 soon. Commented Jul 31, 2013 at 10:08
  • Stock 4.3 has same problem. Commented Jul 31, 2013 at 11:01
  • This is weird! did you try de-authorizing? in case you have more than 10 devices connected to Play Music?
    – Kmelkon
    Commented Jul 31, 2013 at 11:59
  • I did, I only have about 3 devices authorized including this one. Commented Jul 31, 2013 at 20:23
  • I'm sorry, I'm out of ideas.. if you find the solution let us know :)
    – Kmelkon
    Commented Aug 1, 2013 at 7:29

I wrote to google about this issue and they advised to clear app data (Device Menu > Settings > Apps > All > Google Play Music > Clear Data). This worked! However, mind you - you will need to download all your music again if you keep it offline.

  • I think that's because recently Play Music seems to have been updated to fix pinning the Last Added playlist. Commented Nov 21, 2013 at 13:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .